Bedrock 404 error with AMPPS

Hi, trying to get work Bedrock on my Windows with AMPPS.
I created folder in www/bedrock.
In my AMPPS I created domain:
bedrock c:/ampps/www/bedrock/web

This is my .env file:
DB_NAME=bedrock.dev
DB_USER=root
DB_PASSWORD=mysql
DB_HOST=localhost

WP_ENV=development
WP_HOME=http://localhost/bedrock
WP_SITEURL=${WP_HOME}/wp

If I go to http://localhost/bedrock/wp/wp-admin I get:

Not Found - 404
The requested URL was not found on this server.

Normal wordpress installation working.

Thanks for help

Did you do step #4 on the installation instructions? https://github.com/roots/bedrock#installation

Yes this is my vhost file:

<VirtualHost *:80>
    ServerAdmin admin@localhost
    DocumentRoot "C:/wamp/www"
    ServerName localhost
    ServerAlias www.localhost.com
    ErrorLog "logs/localhost-error.log"
    CustomLog "logs/localhost-access.log" common
</VirtualHost>

 
<VirtualHost *:80>
    DocumentRoot "C:/wamp/www/bedrock/web"
    ServerName bedrock.dev
    <Directory "C:/wamp/www/bedrock/web">
        Options Indexes FollowSymLinks MultiViews
        AllowOverride None
        Order allow,deny
        Allow from all
    </Directory>
</VirtualHost>

and this is my hosts file in system
127.0.0.1 localhost
127.0.0.1 bedrock.dev

Normal wordpress on http://localhost/gazebo/ is working fine.

but bedrock.dev redirecting to http://localhost/bedrock/wp/wp-admin/install.php and throwing “Not found”

I solved the issue with installing updated version of wamp server 3.0.6. but still have web in my URL http://localhost/gazebo/web/

I am trying to change my vhost file and host.

hosts file:
127.0.0.1 localhost
127.0.0.1 gazebo.dev

vhost

<VirtualHost *:80>
	ServerName localhost
	DocumentRoot c:/wamp64/www/gazebo/web
	<Directory  "c:/wamp64/www/gazebo/web/">
		Options +Indexes +Includes +FollowSymLinks +MultiViews
		AllowOverride All
		Require local
	</Directory>
</VirtualHost>

I tried to change to different combinations but getting 500 error.
http://localhost/gazebo/wp/wp-admin/install.php

Running windows, wamp, apache

As our instructions mention, the only differencein configuring Bedrock compared to a normal WP install is setting the webroot to the web/ subfolder. So any issues you’re having aren’t specific to Bedrock and non necessarily Roots related.

I’ll leave this thread open in case someone else has a done a setup like yours and can help.

Same problem here. Updated the vhost document as advised, getting a 404 error. Even though URL shows a file (install.php) that exists in the path/to/site/web.

I finally figured it out. All I needed to do (last step) was to copy wp-config-sample.php to wp-config.php and then add the definitions and salts from the .env file. Once i did that, the install proceeded smoothly. So now I have a Wordpress site running Bedrock in an AMPPS localhost domain. You may want to clarify this in the step-by-step installation guide.

Bedrock doesn’t have a wp-config-sample.php.

I know, but obviously Wordpress does.

#5 in installation steps is "Access WP admin at http://example.com/wp/wp-admin." But you can’t get there on a Wordpress site until you activate it. You can’t activate it until you run wp-activate.php. You get a 404 error on trying to reach wp-activate.php unless you configured the site by renaming wp-config-sample.php to wp-config.php. That’s all part of the “famous 5-minute install.” So now when I go to http://localhost/mysite/wp/wp-admin, it looks fine, because I did those 5-minute install steps.

That said, now I’m not sure whether I completed the Bedrock installation correctly. Should the installation steps on https://roots.io/bedrock/docs/installing-bedrock/ not say -

\4. Set your site vhost document root to /path/to/site/web/ (/path/to/site/current/web/ if using deploys)

[between 4 & 5 --> set up your Wordpress site as you would normally, with the “famous 5 minute install” …?]

\5. Access WP admin at http://example.com/wp/wp-admin

I ask because with my install, the Dashboard does not show the themes installed in <sitename>/web/app … which is where you say themes should be installed according to step 3 –

\ 3. Add theme(s) in web/app/themes as you would for a normal WordPress site.

In a “normal” Wordpress site, themes are accessible in wp/wp-content/themes as there is no such folder - that’s one of the things Bedrock adds, isn’t it? Anyway, on the Dashboard, when I go to Appearance>Themes, what I see are themes installed in wp/wp-content/themes - not themes in the web/app/themes folder.

All in all, to be honest, I find the Bedrock installation directions pretty confusing.

OK, so now it looks like I did not do this correctly. According to your description of Bedrock:

The organization of Bedrock is similar to putting WordPress in its own subdirectory but with some improvements, including renaming wp-content/ to app/.

When I ran Composer to install a new Wordpress site, it still had the typical Wordpress site structure, it just added an app directory alongside the wp directory, which in turn is what contains wp-content.

The command I ran (because I am not running composer globally on the CLI) was

/Applications/ampps/www $ php composer.phar create-project roots/bedrock bedrock6

I get a new project folder named bedrock6 and this is what the directory structure looks like:

So at what point in a Bedrock installation is wp-content renamed to app?

Either I am clueless or this is not as clear as it should be - it could be either. :wink:

Don’t mean to flood the thread, but I just tried doing this again, following the five installation steps described. I did everything through step 4 according to plan. As far as I can tell, moving from step 4 to step 5 does not take into account how to accomplish Wordpress site activation and/or renaming of wp-content/ to app/. So I am still stumped!

Maybe what I’m missing is that the only way to actually run a Bedrock-based Wordpress site is what you call "deploy." That is, you cann’t get it working properly on a local box unless you use either Trellis or bedrock-capistrano. Not MAMP or AMPPS. So I guess I read “deploy” too narrowly, thinking it was to “host in a production server environment,” but I think what you mean is “get it up and running anywhere.”

Why are you manually renaming wp-content to app? This is already done for you in Bedrock

Not true at all, just follow step 4 from the installation:

Set your site vhost document root to /path/to/site/web/

I think that you’re overthinking this. The wp folder you can think of as a dependency that you don’t touch, that’s one of the beauties of the Bedrock folder structure. WordPress itself is a dependency, so you never go in there to modify anything.

The wp-content folder being renamed perhaps is a slight misnomer, it isn’t renamed, rather wp-content becomes the app folder because of this. Basically, all of WP is relegated to it’s own folder which can be removed/cleaned out/reinstalled at any point, without ever touching the rest of the user or project files.

Basically, in a Bedrock install, composer install installs WP for you, but you never need to go in and modify anything in the wp folder.

I appreciate your help and guidance. I was just trying to see how this works and was stumped by how to set up Bedrock while running AMPPS for the localhost on a Mac. Then I found a helpful resource that explained how to create a vhost document in MAMP, which is what mystified me earlier, and led me to switch from MAMP to AMPPS.

Once I found that, I switched back to MAMP and the installation steps worked as described. So now I can finally take a closer look at what Bedrock offers in the way of advantages over a typical WordPress installation.

I would just point out that although AMPPS seems a lot more powerful than MAMP, sometimes less is more. The process in terms of adding a domain, changing the vhost record for the domain, etc., does not seem well documented. I will leave it to someone else to figure out how to install Bedrock with AMPSS.

Thanks again!

1 Like