Roots Discourse

Bedrock Sage build production error

Hello everyone. I have an error in the yarn build:production. When i run the yarn build:production it show an error failed to compile with 2 errors in ./resources/assets/styles/main.scss. I have tried a lot but did not found any solution below i attached the screenshot of the error. Your help will be greatly appreciated.

Please detail what you’ve tried so far so that we can better help you.

Based on the error, if looks like the build process is unable to find a font file that is referenced somewhere in your styles. I would double-check that references to fonts in your styles are pointing to the correct location.

Hi thanks for the reply. i tried yarn build and then yarn build production. I also search for the fonts but it is not located in the assests\styles folder. your help will be highly appreciated

Where are the fonts located? I don’t believe Sage includes any fonts by default, so you must have added them to the theme. Whatever path you use to reference them in your styles needs to resolve to an actual font file, otherwise webpack can’t process the font.