Roots Discourse

Bedrock Warning and Fatal Error with Laravel Valet


#1

At wits end trying to figure out how to fix errors like-a-so happening on multiple machines but the working on a different one. Tried full reinstall of Valet, Composer and PHP and recloning and rerunning composer multiple times. Can anyone point me in the right direction? Thanks in advance!!

Warning: require(/Users/username/Sites/domainname/web/wp/): failed to open stream: No such file or directory in /Users/username/.composer/vendor/laravel/valet/server.php on line 147

Fatal error: require(): Failed opening required '/Users/username/Sites/domainname/web/wp/' (include_path='.:/usr/local/Cellar/php/7.2.6/share/php/pear') in /Users/{username}/.composer/vendor/laravel/valet/server.php on line 147


#2

Somehow removed this error on one of the machines by rerunning composer install but now when trying to visit the root of the site it redirects to https://domainname.dev/wp-admin/setup-config.php (note the missing “/wp/” in the path) and it can’t find a config file. (screenshot) and then with a database already imported the proper “/wp/” path https://domainname.dev/wp/wp-admin/ goes to https://domainname.dev/wp/wp-admin/setup-config.php instead of https://domainname.dev/wp/wp-admin/install.php or the proper login screen since the db is properly imported (AFAIK).


#3

Have you verified correct settings in your env file? I just setup a site on valet-wsl for Windows (which is a fork of valet-linux, which is a fork of valet) and had issues that were solved by fixing incorrect paths in my env file. Also may be worth looking at this driver which may be of use https://github.com/danielroe/trellis-valet-driver


#4

Thanks for the reply! The .env file was all good. Only way we could fix this was to start anew with a fresh clone of Bedrock. Looks like there were a few dependency updates but nothing major. Then we copied over the .git directory and theme files and FINALLY good to go. Not ideal but solved it. :expressionless: