Roots Discourse

Big Sur (11.0.1 (20B29))

vagrant version
vagrant plugin list
uname -a
sw_vers

Installed Version: 2.2.13
Latest Version: 2.2.13

You’re running an up-to-date version of Vagrant!
vagrant-bindfs (1.1.8, global)

  • Version Constraint: > 0
    vagrant-hostmanager (1.8.9, global)
  • Version Constraint: > 0
    Darwin alexMACBOOKPRO 20.1.0 Darwin Kernel Version 20.1.0: Sat Oct 31 00:07:11 PDT 2020; root:xnu-7195.50.7~2/RELEASE_X86_64 x86_64
    ProductName: macOS
    ProductVersion: 11.0.1
    BuildVersion: 20B29

Fails with vagrant up/provision:
TASK [wordpress-install : Install Dependencies with Composer] ******************
System info:
Ansible 2.8.0; Vagrant 2.2.13; Darwin
Trellis version (per changelog): “Remove default Vagrant SMB credentials”

Composer could not find a composer.json file in
/srv/www/projectname.com/current To initialize a project, please create a
composer.json file as described in the https://getcomposer.org/ “Getting
Started” section
failed: [default] (item=projectname.com) => {“ansible_loop_var”: “item”, “changed”: false, “item”: {“key”: “projectname.com”, “value”: {“admin_email”: “master@admin.test”, “cache”: {“enabled”: false}, “env”: {“acf_pro_key”: “”, “domain_current_site”: “projectname.test”}, “local_path”: “…/site”, “multisite”: {“enabled”: false}, “site_hosts”: [{“canonical”: “projectname.test”, “redirects”: [“www.projectname.test”]}], “ssl”: {“enabled”: false, “provider”: “self-signed”}}}, “stdout”: “Composer could not find a composer.json file in /srv/www/projectname.com/current\nTo initialize a project, please create a composer.json file as described in the https://getcomposer.org/ “Getting Started” section\n”, “stdout_lines”: [“Composer could not find a composer.json file in /srv/www/projectname.com/current”, “To initialize a project, please create a composer.json file as described in the https://getcomposer.org/ “Getting Started” section”]}

Should we wait for a new vagrant version or VB?

So the mount of the WordPress sites into the Vagrant Trellis VM failed, hence it cannot find a composer.json of a Bedrock site to proceed? Are synced folders working at all on that system?

I think that’s the issue. Vagrant can’t link the folders. Everything in /srv/www/domain.com is there (current/ logs/ shared/) but they are all empty specially current / web.

I’m experiencing the same with the following setup:

  • MacOS Big Sur (11.0.1)
  • Vagrant 2.2.13
  • vagrant-bindfs (1.1.8, global)
  • vagrant-hostmanager (1.8.9, global)
  • vagrant-trellis-cert (0.5.2, global)
  • vagrant-trellis-sequel (0.2.2, global)
  • Ansible 2.9.15
  • VirtualBox 6.1.16 r140961
  • Trellis 1.7.0

The path of my Trellis directory is /Users/davevanhoorn/*****.nl/server and I granted nfsd Full Disk Access in Security and Privacy settings. This also didn’t help.

Minimal test Vagrantfile:

Vagrant.configure("2") do |config|
  config.vm.box = "bento/ubuntu-20.04"
  config.vm.box_version = ">= 201807.12.0"

  config.vm.synced_folder "src/", "/srv/website"
end

When NFS should be used on OSX, some setup is required, see

Thanks @strarsis for the minimal test. I replaced the Vagrantfile in the root Trellis directory and that seemed to work, so I figured it’s something with the Trellis setup.

I changed vagrant_mount_type in vagrant.default.yml and it’s working again. It’s defaulting to nfs (added in this commit), but that isn’t working for me.

Before:
vagrant_mount_type: "nfs"

After:
vagrant_mount_type: "virtualbox"

I can work again :grinning:

2 Likes

Glad to hear that. And yes, the nfs mount type in Vagrant requires additional installation and setup in OSX before it can be used.

1 Like

It runs but I’m just getting 502 (bad gateway). You can launch the *.test URL?

Yes, everything is up and running again. Do you see the files and folders when you vagrant ssh into the local server and check the srv/www/*.test directory?

Ps. I had to do a vagrant destroy and vagrant up --provision before I had it working again.

Ps2. I also had to run the command vagrant hostmanager because the servers IP wasn’t showing in my etc/hosts file

vagrant hostmanager did the trick! thanks!

Now I get really bad performance issues. Anyone that expiring the same here?

Are you currently using NFS for the synced folders, or SMB?

virtualbox that Freshcode is using

Hi everyone. That fix also worked for me! But I also hat to do vagrant hostmanager Thank you.

But before the “Big Sur” Update and switching the vagrant_mount_type I was able to run vargant up for different projects with no problem.
Now only the first VM I execute vagrant hostmanager on will work. The others boot up without an error, but the browser won’t find anything under the local address.
Only after I destroy all VMs and remove ~/.vagrant.d/ it works for that first VM I do vagrant hostmanager on.

Is this somehow connected to the change of vagrant_mount_type?

I also tried to switch it back and give nfs the needed permissions.

But this resulted to the original problem. What am I missing?

Have you set up your OS X system for NFS?


Note the section starting with ‘For OS X, sudoers should have this entry:’.

Isn’t there a way to get the routing fixed with mount_type VirtualBox?
I use trellis, so I don’t have to worry about vagrant’s and other configurations.

The strange thing is, it used to work when I followed all the steps in the trellis docs.

The Link doesn’t reference a specific entry.

For OS X, sudoers should have this entry:

Cmnd_Alias VAGRANT_EXPORTS_ADD = /usr/bin/tee -a /etc/exports
Cmnd_Alias VAGRANT_NFSD = /sbin/nfsd restart
Cmnd_Alias VAGRANT_EXPORTS_REMOVE = /usr/bin/sed -E -e /*/ d -ibak /etc/exports
%admin ALL=(root) NOPASSWD: VAGRANT_EXPORTS_ADD, VAGRANT_NFSD, VAGRANT_EXPORTS_REMOVE

Thanks for this! Where and what file should this be added?

For *nix users, make sure to edit your /etc/sudoers file with visudo

Just a note from a Drupal VM user. I experienced the same issue with vagrant-hostmanager and downgrading from Vagrant 2.2.13 to 2.2.10 fixed it.

2 Likes