Bower error at npm install

I’m getting the below error at npm install and bower (Roots 7.0). I am not using Bedrock, but did do the wp-config tweak noted. Any suggestions on what I should look into. Thanks.

node_modules/.bin/bower install

'node_modules' is not recognized as an internal or external command,
operable program or batch file.

npm ERR! roots@7.0.0 postinstall: `node_modules/.bin/bower install`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the roots@7.0.0 postinstall script.
npm ERR! This is most likely a problem with the roots package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node_modules/.bin/bower install
npm ERR! You can get their info via:
npm ERR!     npm owner ls roots
npm ERR! There is likely additional logging output above.
npm ERR! System Windows_NT 6.1.7601
npm ERR! command "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\nod
ejs\\node_modules\\npm\\bin\\npm-cli.js" "install"
  1. The command is ./node_modules/.bin/bower install Note the ./ to start it with.
  2. I’d recommend just installing Bower globally with sudo npm install -g bower. Then you can just run bower install on its own anywhere.

I’m having the same issue. Tried both things you said but got the following errors for each one:

'sudo' is not recognized as an internal or external command

'.' is not recognized as an internal or external command

Is the idea that after this all works it will generate all the relevant css/js files needed? As none of them seem to exist in the basic roots installation eg main.css and scripts.js.

Whoops. Completely missed you were using Windows. I’m guessing you are as well @pellio11.

This shouldn’t have anything to do with Roots. There’s Windows install instructions for Bower here:

Looks like using git bash works:

Cool cheers that seemed to get it to install though main.css and scripts.js are still missing from the theme. I need to setup grunt commands to minify these etc but where do the initial files come from? These two files are needed for bootstrap styling to work.

That worked for me as well. Along with the note on changing the package.json file with “postinstall”: “bower install” .


You probably already got them showing up by now, but I didn’t have them either so I just started Grunt Watch and then made a change to a LESS file and the main.css got created. I then modified something in Gruntfile.js and when it compiled it created the scripts.js