Browsersync constantly refreshing

This is my first project with Sage 9. I have successfully installed and my browsersync was working fine. Half way through building the homepage I started having a problem with browsersync.

Browsersync is constantly refreshing. Even when not making a change to files.

  • public path seems correct
  • dev url is working although it is a production server (unsure if this matters)
  • when I change the proxy url the refreshing stops, but then the style changes are not being shown (still get web pack built notifications with no errors)

I have tried running fresh yarn builds and deleting the cache loader folder to no avail.

I am out of ideas. Can someone please help.



1 Like

What changed?

If you go back to an unmodified Sage install (other than the local development config settings), is everything fine?

I have been racking my brain trying to find a difference. I didn’t install anything additional. Literally had just started making changes to the scss files and the header partial before the issue started.

I will do a fresh install and see what happens.

Can you share your config.json file?

Thanks for replying Shaimoom. I reinstalled the theme only to have the same problem shortly thereafter.

I feel stupid. This was a cache issue. Once I cleared my cache everything started working again. By clearing cache I mean a hard refresh in chrome. I don’t have to delete the .cache-loader directory.

I am loving sage 9. The controller and blade templates are amazing.


I don’t know how many times I reinstalled sage, started a new project from scratch and copy everything back from the repo, or delete node_modules and reinstalling them through yarn install… if I knew for the past 8months that all I had to do was open it on incognito I would have saved multiple hours of wasted time. Thanks a lot for letting us know! It worked for me

1 Like