Roots Discourse

Browsersync / Yarn start issues

Hi there,

Just wondering if anyone can help me on an issue I’ve been having with Browsersync issues with the Sage theme.

I’m using Laravel Valet, which is parked in a projects directory on my machine. The site in question sits at domain.test.

Running yarn build successfully builds the site, however when running yarn start, the files build and successfully build every time I change a JS/SCSS file however Browsersync is failing to proxy the valet URL, as when I go to https://localhost:3000, Chrome loads for an extremely long time and then throws ERR_TIMED_OUT. Tried in other browsers and get the same issue.

  • There is no firewall blocking that port, as tried with another app which works successfully
  • Tried with and without self signed cert from Valet, and tried http and https links from Browsersync
  • Tried deleting node_modules and running npm install
  • Tried changing the URL of the site
  • Tried a different proxyUrl in config.json
  • devUrl is definitely correct
  • publicPath is definitely correct as it’s building the files

Browsersync doesn’t throw any errors and says

[Browsersync] Watching files…

Been looking at this for two days now and just hopelessly Googling… so just seeing if anyone has had this issue before?

Cheers!

Yeah same problem here. Just started on a new site I am working on. I renamed publicPath to “app/…” instead of “wp-content/…” and it worked for a fews secs lol. Now back to endless reloading of browsersync.

Just read up on this page. Have downgraded (package.json)

“browser-sync”: “~2.24.7”,
to
“browser-sync”: “~2.2.7”,

and it seems to work!

Hi @Mike_Little, glad you got it working, but that wasn’t the solution for me unfortunately !

I think it’s a Mac issue, as the same project was working on my old mac but after swapping to a new one this week even cloning a fresh Bedrock / Sage project doesn’t work.

Yeah started to happen again for me @ciavuc - driving me insane!