Roots Discourse

Bud Exit Code 1

Hello,

I’m trying to figure out what this new bud is and I’m walking through the install. I have the proper node version, the example bud file from the readme.

entry:
  app: "app.{js,css}"

Yet I’m getting only:

$ yarn bud build
yarn run v1.22.15
warning package.json: No license field
$ /…/node_modules/.bin/bud build
error Command failed with exit code 1.

Hey @Ryan2! Thanks for giving Bud a shot!

Can you please provide us with which versions you’re using for both Bud and Node.js?

Bud has been moving pretty fast with all the work that @kellymears and @QWp6t have been doing on it, and the next branch has a lot of improvements over what’s in master if you haven’t yet checked it out!

The last stable release was v4.6.0, but you can find out about a lot of the updates in the next branch here: Release: v4.7.0 | bud.js

1 Like

Hey Ben,

I feel I should go through this much better documentation before wasting time!

Note: I was originally on the hunt for new clover, since there is plenty of PHP to be done. The repo for roots/clover is currently half bud/idk. I ended up just DIYing old Clover, sidestepping Roots\boostrap, and all the Laravel goodness.

Thanks.

Hello I am getting the same error.

I followed BUD’s getting started guide

  1. Created
    ├── package.json
    └── src
    ├── index.js
    └── index.css

  2. Then I run
    $ yarn add @roots/bud --dev
    on the folder where package.json is

  3. When I try to run $ yarn bud --help

I get error below

yarn run v1.22.17
error Command “bud” not found.
info Visit yarn run | Yarn for documentation about this command.

I am using Windows 10.

Are you running these commands from WSL? If not, please use WSL