Bud yarn dev with no style on frontend

Hi everyone, I started a new project based on Bedrock and Sage10.

No configuration files have been modified (it’s a really clean new installation), if I run “yarn dev” the frontend returns the website without any style, but if I run yarn build everything works fine.

Looking at the public folder, with “yarn build” I get a css subfolder, with “yarn dev” the css folder is missing.

Any advice on this? I also searched among the other questions but I did not find a similar situation. Thanks!

CSS isn’t emitted in development. Styles are compiled to memory and injected into the DOM.

Assets won’t be available in development mode through your normal URL. Try http://localhost:3000. which is the URL used by default in Sage.

If you’re still having problems update @roots/bud, @roots/sage, and @roots/bud-tailwindcss to 6.3.2 in package.json:

yarn add @roots/sage@6.3.2 @roots/bud@6.3.2 @roots/bud-tailwindcss@6.3.2 --dev

The 6.3.1 release was problematic for some configurations.


thanks, with 6.3.2 it’s ok :slight_smile: