BudError: @roots/bud-framework tried to access undefined

I have a sage 10 setup working perfectly in ubuntu, I’m trying to make a clone of the same working setup in mac but getting the BudError when runs yarn build or yarn dev:

@roots/bud-framework tried to access undefined, but it isn’t declared in its dependencies; this makes the require call ambiguous and

Also, I saw there are two files auto generating: .pnp.cjs and .pnp.loader.mjs and there is no node_modules folder ever after running yarn install

Can anyone suggest the possible solution to encounter this issue?

Sage: 10.7.0
DevDependencies and versions:
@roots/bud”: “^6.23.1”,
@roots/bud-babel”: “6.20.0”,
@roots/bud-framework”: “^6.23.1”,
@roots/bud-react”: “6.20.0”,
@roots/bud-tailwindcss”: “6.20.0”,
@roots/sage”: “6.20.0”


From Yarn docs:

Remember that migrating to Yarn PnP is optional: you can revert to node_modules installs at any time by setting the nodeLinker: node-modules setting in your project’s .yarnrc.yml file.

Also, from my experience, it is best to use matching versions of all @roots packages, as you are using mixed version numbers.

Good luck,