Roots Discourse

Buffer() Deprecated Yarn warning

Cannot run yarn for theme compilation due to deprecated warning concerning buffer()

non-zero return code
(node:80991) [DEP0005] DeprecationWarning: Buffer() is deprecated due to
security and usability issues. Please use the Buffer.alloc(),
Buffer.allocUnsafe(), or Buffer.from() methods instead.
warning Error running install script for optional dependency:
"/Users/me/Code/domain.com/uniquehotelspa-
com/site/web/app/themes/theme/node_modules/fsevents: Command failed.
Exit code: 1
Command: node install
Arguments:
Directory: /Users/me/Code/domain.com/uniquehotelspa-
com/site/web/app/themes/theme/node_modules/fsevents
Output:
node-pre-gyp info it worked if it ends with ok
node-pre-gyp info using node-pre-gyp@0.6.36
node-pre-gyp info using node@10.1.0 | darwin | x64
node-pre-gyp info check checked for
\"/Users/me/Code/domain.com/domain-
com/site/web/app/themes/theme/node_modules/fsevents/lib/binding/Release/n
ode-v64-darwin-x64/fse.node\" (not found)
node-pre-gyp http GET https://fsevents-binaries.s3-us-
west-2.amazonaws.com/v1.1.2/fse-v1.1.2-node-v64-darwin-x64.tar.gz
node-pre-gyp http 404 https://fsevents-binaries.s3-us-
west-2.amazonaws.com/v1.1.2/fse-v1.1.2-node-v64-darwin-x64.tar.gz
node-pre-gyp ERR! Tried to download(404): https://fsevents-binaries.s3-us-
west-2.amazonaws.com/v1.1.2/fse-v1.1.2-node-v64-darwin-x64.tar.gz
node-pre-gyp ERR! Pre-built binaries not found for fsevents@1.1.2 and
node@10.1.0 (node-v64 ABI) (falling back to source compile with node-gyp)
node-pre-gyp http 404 status code downloading tarball https://fsevents-
binaries.s3-us-
west-2.amazonaws.com/v1.1.2/fse-v1.1.2-node-v64-darwin-x64.tar.gz

4 warnings and 1 error generated.
make: *** [Release/obj.target/fse/fsevents.o] Error 1
gyp ERR! build error
gyp ERR! stack Error: `make` failed with exit code: 2
gyp ERR! stack     at ChildProcess.onExit
(/Users/me/Code/domain.com/domain-
com/site/web/app/themes/theme/node_modules/node-gyp/lib/build.js:258:23)
gyp ERR! stack     at ChildProcess.emit (events.js:182:13)
gyp ERR! stack     at Process.ChildProcess._handle.onexit
(internal/child_process.js:235:12)
gyp ERR! System Darwin 17.5.0
gyp ERR! command \"/usr/local/Cellar/node/10.1.0/bin/node\"
\"/Users/me/Code/domain.com/domain-
com/site/web/app/themes/theme/node_modules/node-gyp/bin/node-gyp.js\"
\"build\" \"--fallback-to-build\" \"--
module=/Users/me/Code/domain.com/domain-
com/site/web/app/themes/theme/node_modules/fsevents/lib/binding/Release/n
ode-v64-darwin-x64/fse.node\" \"--module_name=fse\" \"--
module_path=/Users/jasperfrumau/Code/domain.com/domain-
com/site/web/app/themes/uhs-
theme/node_modules/fsevents/lib/binding/Release/node-v64-darwin-x64\"
gyp ERR! cwd /Users/me/Code/domain.com/domain-
com/site/web/app/themes/theme/node_modules/fsevents
gyp ERR! node -v v10.1.0
gyp ERR! node-gyp -v v3.6.2
gyp ERR! not ok
node-pre-gyp ERR! build error

any ideas to work around this?

Went back to older Node version using nvm install 8.11.2 and then I managed to bypass this error.

Now it only hanged at

TASK [deploy : Reload php-fpm]

For the latter I realized I needed to do a ansible-playbook server.yml -e env=production to update the server and have php-fpm 7.2 there as well. Once that was done all was well. Would actually have been good to have a warning there that reload was not working because version x of php-fpm could not be found / reloaded @fullyint . Just a thought