Cannot login as Admin after renamimg table with table_prefix

sage9

#1

Hi!

i’ve installed a clean version of Bedrock and Sage Theme via wp-cli-valet-command with --dbprefix=mywp_ option.

First, when I create a project with the command wp valet new my-project --dbprefix=mywp_ my tables are still with default wp_ prefix.

Well… Site is working well. So I’ve rename all tables with my custom prefix and set .env file up to date.

But now with my admin login, my capability is minimal (cannot access to dashboard).

When I reverse with table prefix default, it’s ok…

Any clues ? Thanks.
[sorry for my English]


#2

If you didn’t have anything important in the DB, you could drop the database (wp db drop), add DB_PREFIX=my_wp to .env, and then run wp db create to start from scratch.


#3

Thanks for your reply.
I commit a change to use --dbprefix option with wp-cli-valet-command for Bedrock install…
And it’s works now…