Roots Discourse

Cannot start vagrant - issue with NFS

I’ve found a new issue with vagrant, that I’ve never heard of or seen before… I’ve been struggling with it for weeks, so any help or advice would be AMAZING.

I can no longer start up any local servers. When running vagrant up this is the error

==> default: Mounting NFS shared folders...
The following SSH command responded with a non-zero exit status.
Vagrant assumes that this means the command failed!

mount -o vers=3,udp 192.168.50.1:/home/jill/<mysite>/site /vagrant-nfs-<mysite>.com

Stdout from the command:


Stderr from the command:

mount.nfs: requested NFS version or transport protocol is not supported

Deploys still work, though.

Vagrant: 2.2.5

Ansible: 2.3.0.0

Python: 2.7.15rc1

OS: Linux Mint 19 Cinnamon

Cinnamon: 3.8.8

I’ve already tried switching the ansible, trellis, and vagrant versions…

Thank you!

I’m running into the same issue with my existing projects since I updated to Catalina on Mac. I’ve tried so many things but so far no luck.
New installs do work so I guess I’ll have to rebuild the projects on a clean install.

See this thread. There’s an update to Vagrant which fixes this issue on Catalina:

2 Likes

Upgrading to Vagrant 2.2.6 did not fix it for me.

Tried the solution from @janman22 and then got an error about composer not being found on the virtual machine.

Ended up just rebuilding

1 Like

Thank you for your reply! I am not on a mac, though.

Hey thanks for your reply! Could you elaborate a little on what you did to fix the issue?

This was referring to macOS actually haha.

However if you’re on 'nix you usually gotta install it. For example: https://help.ubuntu.com/community/SettingUpNFSHowTo

This doesn’t work :frowning: