Roots Discourse

Can't Enable or Force HTTPS: for Kinsta Staging

Just started a new role at a company that had built their site with Elemental (which I am going to dispose of).

The main logo file is HTTPS: in WordPress, however, when I audit my site I see that there is a single file: http://staging-sureclinical.kinsta.cloud/wp-content/uploads/2019/10/SureClinical-text-logo-blue-small-aug-2019-50px-tall-svg.svg that is appearing as HTTP: Despite having updated it in Wordpress, it is still appearing and is creating mixed content issues.

Live Site on Kinsta is set to force HTTPS: however, for the staging environment Force HTTPS: is not an option nor is Enable HTTPS: (it states that I need to point DNS to Kinsta’s IP which has already been done).

Anyone experience HTTP: issues in Kinsta staging?

You could try wp CLI and use the db search-replace command (first with --dry-run) to find occurences of strings on that site that still use http:// instead of https://.

1 Like

Thank you, found it and repaired!