Chrome won't load .test local site

Hey everyone, I’m a bit of a newbie with this level of local development but have been working my way through the setup process.

All seems well except I cannot get Chrome to load my .test domain local site. It’s running http and not https but both give the same ‘error’, it simply times out. It loads fine on Firefox (although it’s incredibly slow) and super quick on Safari. Obviously, I’d rather do my dev with Chrome.

Any ideas on what might be going wrong?

1 Like

If you’ve ever had ssl enabled for this particular domain, it may have hsts headers set, no longer allowing non-https to load (http might sit then time out). You could clear hsts headers for the domain (visit chrome://net-internals/#hsts), clear cache for site, and try reloading.

It might just be easiest to set ssl enabled: true (with provider: self-signed), then vagrant provision and use https.

If none of the above resolve it, maybe try vagrant up with a vanilla Trellis using a new domain, testing whether a new domain without any hsts or caching history can load in chrome.

If the domain had not loaded in other browsers, I would wonder if you were running into the issue that people encounter with multiple VMs but they forget to assign each a unique IP. But given that other browsers succeeded, I doubt that the IP is the issue.

2 Likes

Thank you. I tried the first step, tried turning SSL back on and reprovisioning. Same problem.

What sorted it in the end was changing from .test to .local. Chrome loads the site instantly. Interestingly .localhost didn’t work either.

1 Like

Explicitly add http:// or https:// in front of your .test domain.

If Chrome never visited that .test domain, Chrome thinks you trying to search instead of going to a web page.

Solution for HTTPS:
Wait for HSTS takes effect. Then you’re good to go.

Solution for HTTP:
Bookmark your .test domain OR visit it so many times that Chrome adds it into autocomplete.