Roots Discourse

Code for hash md5 was not found on trellis deploy

I’m getting this error when trying to deploy my trellis site. It started after I upgrading my macOS. Here’s the full error log

Clearly looks to be an issue with python but I’m also seeing some people mention issues with openssl. I do have a folder called openssl@1.1 in the /usr/local/Cellar/ directory.

Have you installed ansible from scratch after the update?
Have you reinstalled ansible? How have you ansible installed, Python pip?

I have not reinstalled anything since updating. I initially installed them as suggested in the trellis docs

$ sudo easy_install pip
$ pip install ansible

Would force-reinstalling ansible using pip help?

sudo easy_install pip
sudo pip install --upgrade --no-deps --force-reinstall ansible

(https://stackoverflow.com/questions/19548957/can-i-force-pip-to-reinstall-the-current-version)

Just tried that and I still get the hash md5 not found error

What path does which ansible-playbook show?

/usr/local/bin/ansible-playbook

Hm, uninstall ansible completely so ansible-playbook command is not found anymore.
Then install ansible again from scratch.

Hello. I’m having this issue as well. I’ve gone through all the troubleshooting steps above and am still getting that same ‘hash md5 not found’ error.

Hm, not so much can be found about this issue, found one issue that originated from the way how Python was installed: