Roots Discourse

Composer could not find a composer.json file (MacOS Catalina)

I’ve recently upgraded to Mac OS Catalina, and ran into a bunch of problems with my local environment that was up and running fine without issues before upgrading. sigh

Anyway, I got past the initial issue with NFS by recreating the etc/exports directory by running sudo touch /etc/exports and searched several posts here on Discourse but couldn’t find a solution to this error I get when I run vagrant up:
Composer could not find a composer.json file in /srv/www/roots-example- project.com/current

I’ve also upgraded Vagrant, VirtualBox and turned off FileVault and even rebooted. I’ve tried destroying my Vagrant Box, and re-running vagrant up and regardless of whether I use my current project or now the roots-example-project.com - I end up with the same Composer error above.

Any ideas how to resolve this?

I had the exact same issue, and it is all resulting from the fact that Catalina no longer refers to root as just /. Now root is /System/Volumes/Data

This messed up all of my virtual machines, as my sites were all in ~/Sites/. I moved them to my home folder and still the same issues. I moved all of my Sites to a new folder in /System/Volumes/Data/Sites and now I’m able to provision again! with vagrant up --provision (Make sure you delete the old VM’s)

  • KyJax

Just to clarify - that issue is resolved in Vagrant 2.2.6 and you do not need to destroy your VMs, reprovisioning is enough.

Would updating the path in the Vagrant file be enough without physically moving the project directory?

@tjstalcup - seems that directory is read-only, isn’t it? Sorry if this is a stupid question - but how did you move your project folder there?

I feel like i’ve googled/searched every post on discourse to try everything with and no luck whatsoever. I’ve reinstalled Vagrant to the latest with the apparent NFS fix (and tried downgrading to 2.2.5 with updated paths in my Vagrantfile), reinstalled Virtualbox 6.0.14, turned off my Firewall, turned off File Vault… destroyed and provisioned my VMs countless times with my project and the example project, rebooted… same error.

Feels extreme to have to downgrade my OS to resolve this, but not sure what else to do anymore. Any other ideas on how to resolve this?

Unfortunately, the issue was taking too much time and I resolved it by rolling back my OS to Mojave.