Roots Discourse

Composer create fails

PHP: 7.4.11
Composer: 2.0.11 (tried already 1.10.20 originally)

I’m trying to use the bedrock boilterplate but I cannot create a project. When I run composer create-project roots/bedrock I get an error

  • Installing roots/wordpress-core-installer (1.100.0): Extracting archive
    Plugin initialization failed (include(/home/vagrant/code/test/vendor/roots/wordpress-core-installer/src/WordPressCorePlugin.php): failed to open stream: No such file or directory), uninstalling plugin
  • Removing roots/wordpress-core-installer (1.100.0)
    Install of roots/wordpress-core-installer failed

But I can navigate to the src folder and the WordPressCorePlugin.php file is there.

Any ideas? It seems as if composer download the files but couldn’t read/execute them?!

p.s. I’ve already tried stuff like `sudo chown $USER -R ~/.composer
p.s.2 I have no problem installing other packages via composer (e.g. Laravel)

Any ideas?

This topic was automatically closed after 42 days. New replies are no longer allowed.