Composer Permissions Issue


I’m having an issue updating Wordpress via Composer using Trellis and Bedrock.

When I use the Composer Update script via terminal I get the following error:

    Updating johnpbloch/wordpress-core (4.8.0 => 4.8.1):     Update failed (Could not delete web/wp/wp-includes/js/tinymce/plugins/charmap/plugin.js: )
    Would you like to try reinstalling the package instead [yes]? yes
  - Removing johnpbloch/wordpress-core (4.8.0)

  Could not delete web/wp/wp-includes/js/tinymce/plugins/charmap/plugin.js:   

I tried removing the files manually and installed again and got this:

  - Installing johnpbloch/wordpress-core (4.8.1): Downloading (100%)         
  - Updating johnpbloch/wordpress (4.8.0 => 4.8.1):     Update failed (Could not delete /srv/www/ )
    Would you like to try reinstalling the package instead [yes]? no

  Could not delete /srv/www/   

I then deleted the johnpbloch folder and it installed fine. It’s not ideal to manually delete the files every time though.

I think it’s a permissions problem from the VM. I’m using an existing Trellis install but a fresh Bedrock install. This is the first time I’ve tried to update Wordpress.

Has anyone come across this?



1 Like

This is an annoying Vagrant bug that still isn’t fixed

I use finder to change the permissions when this happens (sometimes multiple times a day)


A workaround waiting for the bug to be fixed. From your host machine, perform the following command in the Bedrock folder:

ls -alR > /dev/null


Worked for me, thanks!

1 Like

Hey guys. I’m having the same problem, even if I run the command. Plus I’m having composer caching problems after running it. @ben how did you manage to make it work?


By doing exactly as mentioned in the post. There are also other workarounds as mentioned in the Vagrant issue I linked

Hi flocca, this worked for me. Thanks!

1 Like

Awesome, thanks @flocca!

1 Like

For what it’s worth, I am on 10.13.1 and I’ve tried every option suggested so far, and nothing seems to be working. Still digging.