Conflicting dependencies net-ssh (~> 3.0.1) and net-ssh (= 4.1.0)

Updated Xcode, Brew installed packages and replaced Vagrant:

vagrant -v
Vagrant 2.0.1

as I still seemed to have issues. Then I did a vagrant up and got this:

vagrant up
    Installing plugin vagrant-bindfs
    Bundler, the underlying system Vagrant uses to install plugins,
    reported an error. The error is shown below. These errors are usually
    caused by misconfigured plugin installations or transient network
    issues. The error from Bundler is:

    conflicting dependencies net-ssh (~> 3.0.1) and net-ssh (= 4.1.0)
      Activated net-ssh-4.1.0
      which does not match conflicting dependency (~> 3.0.1)

      Conflicting dependency chains:
        net-ssh (= 4.1.0), 4.1.0 activated

        vagrant (= 1.8.5), 1.8.5 activated, depends on
        net-ssh (~> 3.0.1)

No idea how I can get around this issues. Did a sudo gem update also as I thought that would help, but no joy. Any ideas?

Well, did a

rm -rf ~/vagrant.d
sudo rm -rf /opt/vagrant
rm -f /usr/local/bin/vagrant
sudo pkgutil --forget com.vagrant.vagrant

and had a vagrant up that just installed the plugins:

vagrant up
Installing plugin vagrant-bindfs
Fetching: vagrant-share-1.1.9.gem (100%)
Fetching: vagrant-bindfs-1.0.11.gem (100%)
Installing plugin vagrant-hostmanager
Fetching: vagrant-hostmanager-1.8.7.gem (100%)
`vagrant up` must be re-run now that plugins are installed.

Afterwards I could run the box again. Took me like two hours to work this out… Finally done now.

1 Like