Could not find the requested service "'mailhog'"

Hey there!

I’m using Trellis for the first time, and following the instructions results in an unsuccessful ‘vagrant up’.

The entire thing goes through fine, but then we hit this line:

TASK [mailhog : Ensure mailhog is enabled and will start on boot.] *************
System info:
  Ansible; Vagrant 1.8.6; Darwin
  Trellis at "Update to WP-CLI 0.25.0 for WP 4.7 compat"
Could not find the requested service "'mailhog'":
fatal: [default]: FAILED! => {"changed": false, "failed": true}

Here’s the recap output:

PLAY RECAP *********************************************************************
default                    : ok=43   changed=33   unreachable=0    failed=1   

Ansible failed to complete successfully. Any error output should be
visible above. Please fix these errors and try again.

Tried vagrant destroy followed by another up; tried deleting the entire repository and starting over again. Exact same issue.

I’m on macOS 10.12.1, and have installed all dependencies listed in the Github repo. Have also followed all installation steps, and have configured my group_vars correctly.

Any ideas? I couldn’t find other topics related to this.

Seconded, I’m having the same issue. I also went back to Trellis 0.9.8, but it had the same issue. I’m on Ubuntu 16.04.

System info:
Ansible; Vagrant 1.8.5; Linux
Trellis 0.9.8: August 14th, 2016

Looks like you are using Ansible released 3 days ago, which version caused an issue with Mailhog and was fixed just yesterday. To use Ansible 2.2, Trellis will need to update from Mailhog 1.1 to yesterday’s release of 2.1.

Anyone is welcome to explore the implications of such an upgrade and submit a pull request.

In the meantime, you could be back up and running if you use an Ansible less than 2.2, e.g.,

pip install ansible==

It works! Thanks for the help!


In the meantime, you could be back up and running if you use an Ansible less than 2.2, e.g.,

@fullyint you’re the man, thanks for responding so quickly! That’s gotten me back up and working, and I’ve filed a Github issue with the relevant information. :slight_smile:

1 Like

roots/trellis#681 updated the MailHog galaxy role and others to be compatible with Ansible 2.2

1 Like

I just got my first successful vagrant up for (yay :grinning:)

On the way I got the same mailhog error message using

  • latest Trellis that seems to include roots/trellis#681
  • latest vagrant (1.9.0)
  • latest ansible (

Using Vagrant 1.8.7 gives same error

Using Ansible works