Roots Discourse

Default install of Sage 9 beta showing blank page

Hi, I installed and set up Sage 9 beta 4 and ran through all the steps, using just Bootstrap and Font Awesome. Created 5 pages, a menu with them and set static page. I left the blade templates at default settings just to have a look at the default menu before trying to add bootstrap navwalker. Running yarn run start (after building and minifying everything for production) just shows a totally blank page with not even a default primary menu for the 5 pages. Also Firefox says theres no stylesheet attached at all. Clearly missing something here, does anyone know what ?

DONE Compiled successfully in 26461ms 20:46:14

                                Asset       Size  Chunks             Chunk Names

vendor/fontawesome-webfont_674f50d2.eot 166 kB [emitted]
vendor/fontawesome-webfont_af7ae505.woff2 77.2 kB [emitted]
vendor/fontawesome-webfont_fee66e71.woff 98 kB [emitted]
vendor/fontawesome-webfont_b06871f2.ttf 166 kB [emitted]
vendor/fontawesome-webfont_912ec66d.svg 6 bytes [emitted]
scripts/main_008b99a5.js 72.6 kB 0 [emitted] main
scripts/customizer_008b99a5.js 754 bytes 1 [emitted] customizer
styles/main_008b99a5.css 207 kB 0 [emitted] main
assets.json 681 bytes [emitted]
Done in 30.39s.
[anton@localhost sage9]$

Thanks

1 Like

I have to check the docs to see what part of this process is unclear because we get a lot of questions in this general area.

yarn start will not compile and output assets to your dist directory. Instead it starts a browsersync session at http://localhost:3000 where your styles will be injected in real time as you save your changes.

To compile your styles and emit them to your dist directory type yarn build. To compile and minify your styles and remove sourcemaps for production, type yarn build:production.

What’s the output of the page source - is it entirely blank? If so, sounds like you didn’t configure your devUrl (or publicPath) correctly in resources/assets/config.json as mentioned in https://github.com/roots/sage#theme-development

1 Like

Its completely blank with no stylesheet attached. The devurl is just localhost/sage9 which is the name of the wordpress installation folder in /var/www/html root (standard apache linux stack) and the PublicPath is /wp-content/themes/sage9 (same theme name as the wp installation folder.) There is no page source either!

Reinstalled Wordpress 4.8 in standard wordpress root folder and transferred the theme after changing dev and public urls, exactly the same error.

Again reinstalled wordpress with the 3 default themes, They are selecting and showing with 5 pages + menu etc fine. Intstalled and built Sage 9 beta, selected the theme, shows a blank page with no menu ? (Changed dev an public urls to suit)

Twenty Seventeen theme

Sage 9 theme

Can you screenshot your appearance/themes screen? Sometimes WP gets confused about Sage themes and tries to activate them from inside /resources.

As above ?

Its got a little worse, now after building everything with yarn in to dist folder and switching to sage9 theme, there are errors with illuminate, no uploads directory/files.

Have you run composer install from inside the Sage directory?

It should be giving you better errors even if you haven’t…

I reinstalled and built everything I ran composer install and its already done ie:
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Nothing to install or update
Generating autoload files
[anton@localhost starter]$

Chrome console shows no sources whatsoever so it looks like wordpress is detecting the theme but not loading it correctly.

Not getting the illuminate errors now.

Check the permission of cache. For view the error message. set WP_DEBUG to true.

Any news with this problem, I’m getting exactly the same

Also experiencing the same blank screen. No errors, no source, nothing.

Check your PHP error logs. Usually this kind of behavior means that a PHP script is throwing a fatal error, but your server is not configured to print errors out.

1 Like

I get 3 warnings because “wp-content/uploads/cache/a6944b956f2942900cd20a06b07124e345620452.php” doesn’t exist. But there is no fatal errors. If I create the file I don’t get any errors, just a blank page with no php errors, just nothing.

Don’t create those files, they need to be automatically generated. Try removing your uploads/cache directory entirely.

See also: https://github.com/alwaysblank/blade-generate

1 Like

When I install Sage, it doesn’t create the “upload/cache” folder, that is why I get the error, I tried to create it by myself but it didn’t work.

I have tryed https://github.com/alwaysblank/blade-generate and it works! thank you very much!

2 Likes

For the include(): Failed opening… error. What I did is to create cache folder under uploads and it works.

1 Like

I’m using linux mint and when installing lamp I had the problem that when activating the theme I loaded blank only the file index.php solved it by adding permissions to the folder wp-content

chmod -v 777 wp-content

and uploads/cache could be created

and now everything works fine for me. :slight_smile: