Roots Discourse

Dependabot fails to find latest versions of wpackagist plugins

This isn’t exactly about roots.io, but I’m hoping someone could shed some light, as dependabot appears widely used with bedrock.

Dependabot fails to find latest versions of wpackagist plugins - a piece of a log:

  proxy | 2020/09/29 13:39:10 [090] GET https://wpackagist.org/p/wpackagist-plugin/simple-history%247a846f99859bb97aca1e2ecfd68a2dd41136bf59fb28ae0d74e005cf84e43db3.json
  proxy | 2020/09/29 13:39:10 [090] 200 https://wpackagist.org/p/wpackagist-plugin/simple-history%247a846f99859bb97aca1e2ecfd68a2dd41136bf59fb28ae0d74e005cf84e43db3.json
...
updater | INFO <job_49149746> Checking if wpackagist-plugin/simple-history 2.36.0 needs updating
  proxy | 2020/09/29 13:41:49 [149] GET https://wpackagist.org:443/packages.json
  proxy | 2020/09/29 13:41:50 [149] 200 https://wpackagist.org:443/packages.json
  proxy | 2020/09/29 13:41:50 [151] GET https://wpackagist.org:443/p/wpackagist-plugin/simple-history.json
  proxy | 2020/09/29 13:41:50 [151] 404 https://packagist.org:443/p/wpackagist-plugin/simple-history.json
  proxy | 2020/09/29 13:41:50 [153] GET https://wpackagist.org/packages.json
  proxy | 2020/09/29 13:41:51 [153] 200 https://wpackagist.org/packages.json
  proxy | 2020/09/29 13:41:51 [155] GET https://repo.packagist.org/packages.json
  proxy | 2020/09/29 13:41:51 [155] 200 https://repo.packagist.org/packages.json
updater | INFO <job_49149746> Latest version is 
  proxy | 2020/09/29 13:41:53 [157] GET https://wpackagist.org/packages.json
  proxy | 2020/09/29 13:41:54 [157] 200 https://wpackagist.org/packages.json
  proxy | 2020/09/29 13:41:54 [159] GET https://repo.packagist.org/packages.json
  proxy | 2020/09/29 13:41:54 [159] 200 https://repo.packagist.org/packages.json
...
updater | INFO <job_49149746> Requirements to unlock update_not_possible
updater | INFO <job_49149746> Requirements update strategy bump_versions_if_necessary
updater | INFO <job_49149746> No update possible for wpackagist-plugin/simple-history 2.36.0

The first link there looks good to me, but then there’s one that’s not good, and a line that says…:

updater | INFO <job_49149746> Latest version is

… and finally the conclusion that update’s not possible.

That’s an example with just one plugin (which I first manually downgraded for testing purposes); however, all plugins from wpackagist similarly have no value where it says "Latest version is ".

I’ve initially run composer require wpackagist-plugin/simple-history and composer.json has lines such as: "wpackagist-plugin/simple-history": "^2.36,"

Any thoughts? What could be wrong?

Ps. Some parts of the log look OK so things aren’t completely off, for instance:

updater | INFO <job_49153359> Checking if roots/wordpress 5.5.1 needs updating
  proxy | 2020/09/29 14:42:56 [116] GET https://wpackagist.org:443/packages.json
  proxy | 2020/09/29 14:42:56 [116] 200 https://wpackagist.org:443/packages.json
  proxy | 2020/09/29 14:42:56 [118] GET https://packagist.org:443/p/roots/wordpress.json
  proxy | 2020/09/29 14:42:56 [118] 200 https://packagist.org:443/p/roots/wordpress.json
updater | INFO <job_49153359> Latest version is 5.5.1
updater | INFO <job_49153359> No update needed for roots/wordpress 5.5.1

I got Renovate going, instead.

Renovate is also nice because it can be used opensource with a private GitLab server.