Roots Discourse

Deploment with Deploybot failing with Incompatible Module

Hi all,

I’m trying to sync my git repository by following this post:

https://roots.io/guides/automate-sage-9-deployment-with-deploybot/

Every deployment is failing so far with the message.

‘error Found incompatible module’.

Deploybot’s advice was to update the Build commands to include Node 15 as the container uses 10, this didn’t work.

The only issue i seem to have is with Carbon using V1, when I upload manually via FTP I get a message that says this:

Shared with CloudApp

Although I’m not sure if they are related and I’m not sure i need to upgrade Carbon.

Apologies for the slight vagueness of the request I don’t have any more detail I can give to assist. If anyone knows how to start troubleshooting I’d be grateful.

Regards

Chris