Deploy to Digital Ocean droplet with no Domain?

(Very) late yesterday after a surge of inspiration I spun up a local Trellis install with the intention of showing a potential client a site concept. All perfect. Once it was done, I then made a digital ocean droplet and went to provision/deploy to it. At this point I realised that I have no domain name for this project to point to. I don’t really want to purchase one just for this purpose.

Is there a way to use just the IP address of the droplet? If so, what would be the site hosts settings in my production wordpress_sites.yml file?

I haven’t tried IP only recently, so I don’t remember if it works. You could try:

      - canonical:

or perhaps

      - canonical:
      - canonical:

You’ll probably need to have ssl enabled: false.
Then reprovision (server.yml).

See also:


Has anyone done this successfully? I will be testing here shortly but am waiting for some downloads to complete.

I believe this has worked for me in the past, like a few + years ago.

1 Like