Roots Discourse

Disable EsLint - Please help!

Hi

How do I disable es lint? It is just constantly getting in my way and is infuriating.

I use 4 space indent not 2, it is just easier to read!

I have tried everything in the .eslintre.js

current rules:

'rules': {
        'no-console': 0,
        'quotes': ['error', 'single'],
        'indentation': 'off',
        'indent': 'off',
        "no-unused-vars": "off",
        'comma-dangle': [
        'error',
        {
            'arrays': 'always-multiline',
            'objects': 'always-multiline',
            'imports': 'always-multiline',
            'exports': 'always-multiline',
            'functions': 'ignore',
        },
        ],
    },

The off on the indent is having no effect.

.editorconfig

root = true

[*]
indent_style = space
indent_size = 4
end_of_line = lf
charset = utf-8
trim_trailing_whitespace = true
insert_final_newline = true

[*.php]
indent_size = 4

[resources/views/**.php]
indent_size = 4

[*.md]
trim_trailing_whitespace = false

[*.blade.php]
indent_size = 4

Example of the error I want to disable:

 45:5  ✖  Expected indentation of 2 spaces                           indentation
 45:8  ✖  Expected newline after ":" with a multi-line declaration   declaration-colon-newline-after
 48:5  ✖  Expected indentation of 2 spaces                           indentation

What is strange/ infuriating is that I have another Sage install with running the same version but I am not getting these errors.

Php storm formats all of my code, so I just need this to get out of my way so I can work! :cry:

Currently I have just removed

    // new StyleLintPlugin({
    //   failOnError: !config.enabled.watcher,
    //   syntax: 'scss',
    // }),

Is there another way?

Comments can be used to disable certain stylelint rules:

/* stylelint-disable no-descending-specificity */
// some naughty styles
/* stylelint-enable */

Check the ESLint documentation about the indentation rule:

1 Like

Thanks for the reply, will take a look.

that was usefull and work for my styling,but doesn’t work with my external js