.Env failed to create - error 26

Hi, I’m trying to get Bedrock-Ansible setup on Windows 8.1

So far I have Vagrant VM up and running. Ansible is run from within the VM.

I am using the VagrantFile and a modified version of the windows.sh script (uses pip to get ansible from the this link https://gist.github.com/swalkinshaw/5266b6869fcbbedf074d

Once I run ‘vagrant up’ my setup fails I am unsure what to do. Please advise.

defautl: TASK: [wordpress-install | Create.env file]

default: msg: Could not replace file: /root/.ansible/tmp/ansible-tmp-1431371072.61-26356912638911/source to /srv/www/example.com/current/.env: [Errno 26] Text file busy

Yep, this and a few other issues are solved in this PR: https://github.com/roots/bedrock-ansible/pull/203

Your particular issue is some silly issue with the normal shared folder not being able to be written directly to it. The workaround is here: https://github.com/kalenjohnson/bedrock-ansible/blob/bbfca1b5e560eefa706ac311abb7fc8d9eeb4e2c/roles/wordpress-install/tasks/main.yml#L4-13

1 Like

Thank you so much for the quick response and solution!

I am trying it out now.

I’ve hit another issue in my setup. Once I get that fixed, I’ll let you know how this went

Everything is up and working! Thanks so much for your post!!!