Roots Discourse

Error locating ../app/helpers.php for inclusion

There’s an sage error I’m getting on my site that has me completely lost, Error locating ../app/helpers.php for inclusion.

Long story short there was a developer who left us trying to build off of a half working project (we’re unable to locally build the sage theme) so we’ve been manually editing the blades and compiled code and it’s been working, but yesterday this error popped up and I can’t figure out why. We’re unable to access the site or the WP admin panel.

Can anyone offer any guidance? If you need more information than I have given please let me know.

This existing post may help here, seems related. Also had issues with helpers.php etc.

Thanks Jordan, I did look at that before posting here (That post was actually the reason I know about this site) but it’s not a case issue with the App/app seeing how it was working fine up until yesterday.
/var/www/html/web
image

Any other ideas that may put me in the right direction?
Edit:
Does this look correct:
/var/www/html/web/app/themes/sage
image

Your error is being thrown by Sage, which means that Sage can’t find a file in your theme. Your screenshots show an app folder as part of your site structure above your theme; that’s not the folder that the error is referring to. Your screenshots do not show an app folder in your theme (Sage), which is what the error is referring to. Inside of your theme there should be an app folder that contains helpers.php in addition to some other files. You can see what the structure of a Sage theme is supposed to look like by taking a look at the Sage repo: https://github.com/roots/sage

As to why the error only appeared now, I couldn’t say based on the information you provided. That file is loaded very early on in the process of Sage starting up, so either it was there before and was removed, or you somehow enabled code to load it that was previously inactive.

Thank you Always, for some reason the apps folder was put into the config directory…