Error on vagrant up - Windows 8.1

Hi guys,
After some tinkering and getting used to the new changes I get the following error after running ‘vagrant up’:

TASK: [php | Start php5-fpm service] ******************************************
failed: [] => {"failed": true}

FATAL: all hosts have already failed -- aborting

PLAY RECAP ********************************************************************
       to retry, use: --limit @/root/dev.retry                  : ok=29   changed=13   unreachable=0    failed=1

I’ve cloned both bedrock and sage as per the example:

For vagrant I have installed the vagrant-hostsupdater and have cloned @kalenjohnson 's windows compat branch:

As I have found to be the case I have started the git-bash console with admin priviledges as it otherwise won’t have enough permissions to change the hosts file.

I’ve tried to minimize errors by not changing much in my development file:

mysql_root_password: devpw

web_user: vagrant

    local_path: '../site' # path targeting local Bedrock site directory (relative to Ansible root)
    site_install: true
    site_title: roots Site
    admin_user: admin
    admin_password: admin
      enabled: false
      subdomains: false
      enabled: false
    system_cron: true
      wp_env: development
      db_name: example_dev
      db_user: example_dbuser
      db_password: example_dbpassword

php_error_reporting: 'E_ALL'
php_display_errors: 'On'
php_display_startup_errors: 'On'
php_track_errors: 'On'
php_mysqlnd_collect_memory_statistics: 'On'
php_opcache_enable: 0

xdebug_install: false
php_xdebug_remote_enable: true
php_xdebug_remote_connect_back: true
php_xdebug_remote_host: localhost
php_xdebug_remote_port: 9000
php_xdebug_remote_log: /tmp/xdebug.log
php_xdebug_idekey: XDEBUG
php_max_nesting_level: 200

Any help would be very welcome


Ok so it seems to be related with Ansible version 1.9.1 as mentioned by @kalenjohnson:

How could I revert back to version as mentioned in the pull request?


You’re running into an issue with Ansible 1.9.1 specifically.

Yes @kalenjohnson I finally figured it out.
I was wondering however if there is a way for me to revert back to as you mention on github.


I looked into that, but it didn’t seem like the Ansible PPA allows installing previous versions. Hopefully the next version with the fix is out soon

Thanks a lot. This would be the next version on Ansible or bedrock-ansible?

So if I were to use a bedrock-ansible, bedrock & Sage combination right now with Windows what would be my best bet?


The next version of Ansible, it’s an Ansible bug. You can remove this section, as it’s not even necessary if you haven’t changed the default Vagrant box, as php5-fpm is already installed and running:

Although if you use bedrock-ansible to provision a staging/production server you may need to add that back in.

Thanks that worked. Now I’m running into the directory length problem with npm:

OSError: [Errno 2] No such file or directory: '/srv/www/'

The file it’t there, however it seems that Ansible (Vagrant?) is not able to go beyond the 260 character limit.

I’m wondering if anybody else is running into this problem as it hasn’t been raised until now.



I don’t know much about that. I’ve seen people ask about that issue in Windows but I don’t know the fix. I don’t actually use Windows on any of my machines for development :slight_smile:

Not a problem :slight_smile: Thanks for all your help. Hopefully with Vagrant 1.7.3 and UNC fix the problem will be corrected.

Thanks again