ERROR! Unexpected Exception, this is probably a bug: No module named six

I have two computers. One is a Linux Ubuntu 17.04 with GNOME, the other is a Mac OS Sierra 10.12.6.

A few days ago I finish development on a new site and I go to deploy to Staging and I get this ERROR! Unexpected Exception, this is probably a bug: No module named six.

I waste my time attempting to debug it.

So I switch to my Mac. I go to deploy and I get this error: SSH Error: data could not be sent to the remote host. Make sure this host can be reached over ssh.

So I confirm I can SSH into my newly created DO Droplet using root@ and that works. I confirm my ~/.ssh/known_hosts file gets updated accordingly and I rerun. Same error.

So I waste more time trying to debug and I come across this post:

I run pip install ansible==2.2.2, as advised as a first step in the post and now I get this error ./bin/ line 45: ansible-playbook: command not found

So I execute pip uninstall ansible get some more errors. Reinstall following the official documentation that states I reinstall using sudo pip install ansible and re-run the original deploy.

Now I am getting the same error I was getting on my Linux machine.

I have done as much research on this issue and how to resolve it as possible. Including trying to install module six, which made no difference.

Can someone please help? I am willing to pay.

Executing pip install ansible== resolved this issue for me on Mac and Linux.

I don’t know what version of Ansible I was running but I’m guessing it was 2.4 because of this post.

Sorry to hear it.

Nope, that wasn’t the advised first step. @fullyint said “make sure you have Trellis updated to support 2.3, or install Ansible 2.2.2”. Ansible 2.3 support was merged in on April 15. So unless your project was started and not updated since then, then you shouldn’t have tried to use an older version of Ansible.

Thanks for the swift reply.

I must have downgraded and I can understand how that would break things. I was surprised it was so abrupt. But thankfully it’s resolved now.

@swalkinshaw would you be willing to explain why this was unlisted?

We frequently unlist threads to keep the main forum/search results clean. Usually this is done to threads which we believe are a pretty specific/unique issue (this thread) or not really relevant to Roots.

It doesn’t really mean anything beyond that.

Okay, thank you for the swift response Scott.