Errors Generating autoload files on install

Heyo. Working with Sage for the first time and having a little trouble with the setup. When I run composer create-project roots/sage my-theme-name

…I get the following errors.

Generating autoload files

Roots\Sage\Installer\ComposerScript::postCreateProject
sh: -c: line 0: syntax error near unexpected token (' sh: -c: line 0:php /Users/Dylan/Google Drive (dylan@eclat.digital)/Local Sites/sage/app/public/wp-content/themes/sage-child-dg/vendor/roots/sage-installer/bin/sage meta’
sh: -c: line 0: syntax error near unexpected token (' sh: -c: line 0:php /Users/Dylan/Google Drive (dylan@eclat.digital)/Local Sites/sage/app/public/wp-content/themes/sage-child-dg/vendor/roots/sage-installer/bin/sage config’
sh: -c: line 0: syntax error near unexpected token (' sh: -c: line 0:php /Users/Dylan/Google Drive (dylan@eclat.digital)/Local Sites/sage/app/public/wp-content/themes/sage-child-dg/vendor/roots/sage-installer/bin/sage preset’

The following page is displayed when I try to access the wp-admin:

Sage › Error
Autoloader not found.
You must run composer install from the Sage directory.

Any thoughts would be greatly appreciated.

Hey @dylan.digital - the parentheses in your path (or the spaces, or both) are breaking the command. I’ll work on getting this fixed in roots/sage-installer, but in the meanwhile you have a couple of options:

  1. Change your path to remove the parentheses (and if necessary the spaces)
  2. Apply the fix from this PR and rerun composer create-project
2 Likes