Example project (trellis/bedrock) won't 'vagrant up'

In the example project it tells you to drop Trellis’s vagrantfile into the project root like this(so that it’s in the root, not Trellis folder).

Here is the cheatsheet I’m following (skip to step #4.0).

When I get to step #8.1 where I vagrant up, it gives me this error:

An error occurred while downloading the remote file. The error
message, if any, is reproduced below. Please fix this error and try

Couldn't open file /Users/[username]/Sites/[project-name]/base

I’m not sure what I’m doing wrong. It vagrants up just fine when I do it inside the Trellis folder, but the example project specifically says to drag the vagrantfile into the root. I’m assuming that’s where I’m supposed to run it.

Any clarification or tips on what I might be doing wrong would be extremely helpful, thanks guys!

Hi @masoninthesis,

Can you please post the contents of your Vagrantfile and also group_vars/development? I think personally it would be easier for you to follow the roots documentation as it should be reliable but it also means that we are all on the same page so to speak.

EDIT: Please post your project folder structure too.


Hey Craig,

Thanks for the response.

Here is the project: https://github.com/masoninthesis/jackalope.io--3.0



1 Like

That Vagrantfile in your root is bogus. Open it up in a text editor.

@austin beat me to it, but yeah, you have two copies of the Vagrantfile. The one in your project root has almost everything commented out. I’m guessing you just need to replace it with the Vagrantfile currently in your trellis directory, like in the example project step 5.

Thanks guys!

So I fixed that, and I’m still not vagranting up right.

I tried changing the ansible_path specified on line 14 to– ‘trellis/group_vars/development’. But that gave me a much nastier error.

What happens if you do this from the example project step 5:

and update the ANSIBLE_PATH to ‘ansible’

I get this error, same as the first:

It looks like the Vagrantfile in the example project is set to: 'group_vars/development'

Edit: oh, standby, I’m onto something.

Ok, now that your Vagrantfile is in your project root:

 ├── site/
 ├── trellis/
 └── Vagrantfile

I think you’re running into an issue having renamed the ansible directory trellis. You’ll need
ANSIBLE_PATH = 'trellis'

Rad! That makes so much sense. :stuck_out_tongue:

I’m still getting an error, but I’m a lot closer:

Idk where it’s getting ‘/example.com/’, because it should be ‘/jackalope.io/’ from, but I’ll do a fresh install and see if I can fix it.

You need to open up /etc/exports in your favorite text editor and remove invalid entries


Cool, I had no idea what /etc/exports was, or where it was located– but this answer on Stackoverflow solved it for me.

Well now I’ve vagrant’ed up and my VM is running. It seems like I’ve done the installation process correctly, which is awesome. But now I have a really stupid question. :pensive:

Here’s the current github repo.

Idk which local web address to pull up Sage. My /group_vars/development file says example.dev, but that doesn’t seem to pull it up.

I think I might have missed an important step within Wordpress configuration. Before Trellis I was using VVV and I didn’t have to configure anything manually.

Go to /etc/hosts and see if example.dev shows up

If it’s not there I bet you $5 you skipped over the part in the readme that says to install vagrant-hostsupdater

1 Like

Perfect. It worked.

You were mostly right about vagrant-hostupdater. I actually had installed it, but the file was corrupt. /etc/hosts had multiple domain names listed. I think that’s probably due to updating group_vars/development after running vagrant up. Seems to work fine if you do a vagrant reload.

Thanks for sticking with me on that one Austin!

1 Like