Roots Discourse

First install: nothing happens when running 'vargant up'

I first installed all required stuff from “macOS Basic Setup”, “macOS Development Environment: Sage” and " macOS Development Environment: Trellis" tutorials. On a mac.
I am now a the end of the “Installing Trellis” documentation. I am now stuck at the ‘vagrant up’ command. When I run the command (from Trellis folder). Nothing happens at all.

What can I do?

Hey Nicolas,

I first installed all required stuff from “macOS Basic Setup”, “macOS Development Environment: Sage” and “macOS Development Environment: Trellis” tutorials. On a mac.

I have never heard about these docs, working on a Mac myself… Please provide a link.

What can I do?

Please confirm that you meet the requirements specified in the Trellis docs:

You can test each of those via the -v flag, f.ex. composer -v will output the current version / build. If you receive an error then you know you need to install those first.

Regards!

Hi Evance, thank you for your reply!

These are the docs I was mentioning:
https://roots.io/getting-started/docs/macos-basic-setup/
https://roots.io/getting-started/docs/macos-development-environment-sage/
https://roots.io/getting-started/docs/macos-development-environment-trellis/

I also followed this tutorial until the ‘vargant up’ command

Here is my setting:
Composer 1.9.2
Virtualbox 6.1
Vagrant 2.2.7

The command “vagrant -v” didn’t work (same as “vagrant up”) so I started to doubt vagrant was even installed. Eventually found out it was installed and re-installed it but anyways result is still the same: nothing happens when I try to run the command “vagrant up” inside the trellis folder.

Does it work now after re-installation? You need to have Vagrant installed correctly, that seems to be the culprit – otherwise you’d receive at least some kind of error message.

You can try to install via .dmg vs. brew cask install vagrant maybe…?

Didn’t change, but I could see the version after re-install. I’ll try with dmg and report.

Unistalling Vagrant from command and re-installing it from the site dmg didn’t change the problem. Vagrant commands don’t give any response.

Hmm… This seems to be a vagrant-specific error then and as such not related to Trellis / the Roots-stack :no_mouth:

See the vagrant docs for further guidance.

Couldn’t find any solution from vagrants docs and discussion group so far. If anybody has a clue why vagrant isn’t working on my machine let me know please.

You said that vagrant -v returns the version. Have you tried running Vagrant with debug enabled? See here: https://www.vagrantup.com/docs/other/debugging.html It sounds like something during the early startup is causing Vagrant to hang, possibly indefinitely, and debug might help you spot where/why that happens.

Thank you for your message @alwaysblank! Unfortunately vangrant -v didn’t work just like any other vagrant commands in the document you suggested.