Roots Discourse

First time user: Stuck on vagrant up command

Hello!

I’m trying to learn roots and downloaded and followed the instructions to set up the example project.

Also, i’m running all of this in a ubuntu instance inside a virtual box installed on windows.

Here’s the log of what happens:

vagrant up
Bringing machine 'default' up with 'virtualbox' provider...
==> default: Checking if box 'bento/ubuntu-18.04' version '201812.27.0' is up to date...
==> default: Clearing any previously set forwarded ports...
==> default: Vagrant has detected a configuration issue which exposes a
==> default: vulnerability with the installed version of VirtualBox. The
==> default: current guest is configured to use an E1000 NIC type for a
==> default: network adapter which is vulnerable in this version of VirtualBox.
==> default: Ensure the guest is trusted to use this configuration or update
==> default: the NIC type using one of the methods below:
==> default: 
==> default:   https://www.vagrantup.com/docs/virtualbox/configuration.html#default-nic-type
==> default:   https://www.vagrantup.com/docs/virtualbox/networking.html#virtualbox-nic-type
==> default: Clearing any previously set network interfaces...
==> default: Preparing network interfaces based on configuration...
    default: Adapter 1: nat
    default: Adapter 2: hostonly
==> default: Forwarding ports...
    default: 22 (guest) => 2222 (host) (adapter 1)
==> default: Running 'pre-boot' VM customizations...
==> default: Booting VM...
==> default: Waiting for machine to boot. This may take a few minutes...
    default: SSH address: 127.0.0.1:2222
    default: SSH username: vagrant
    default: SSH auth method: private key
Timed out while waiting for the machine to boot. This means that
Vagrant was unable to communicate with the guest machine within
the configured ("config.vm.boot_timeout" value) time period.

If you look above, you should be able to see the error(s) that
Vagrant had when attempting to connect to the machine. These errors
are usually good hints as to what may be wrong.

If you're using a custom box, make sure that networking is properly
working and you're able to connect to the machine. It is a common
problem that networking isn't setup properly in these boxes.
Verify that authentication configurations are also setup properly,
as well.

If the box appears to be booting properly, you may want to increase
the timeout ("config.vm.boot_timeout") value.

On executing “vagrant halt”:

vagrant halt
==> default: Attempting graceful shutdown of VM...
    default: Guest communication could not be established! This is usually because
    default: SSH is not running, the authentication information was changed,
    default: or some other networking issue. Vagrant will force halt, if
    default: capable.
==> default: Forcing shutdown of VM...

(I’ve been strugling with this for 3 days now, tried every solution I could find and nothing worked
)

Hi Raphael_Araujo_Lima, welcome to roots!

Open the virtualbox program (Oracle VM Virtualbox Manager)
Select the virtual machine your running this on
Click SETTINGS -> NETWORK -> is the checkbox “Cable Connected” checked?

1 Like

Hi @JordanC26! Yes, it’s checked.

Try to turn on the GUI in the Vagrantfile and check the Virtualbox booting if there is a error or something which keeps it waiting. I had the same problem some time ago and it happened that it was an error dialog.

config.vm.provider :virtualbox do |vb|
  vb.gui = true
end
2 Likes

Thanks @dsemblano it worked! Not without some more hiccups tho…

For anyone who are still struggling with this here’s what happened:

After I did what dsemblano mentioned I got the error that VT-x/AMD-V wasn’t availble in my system. after a little poking around I found out that I had to enable this option in order to work on my virtual box:

image

After that the machine starter and asked for vagrant user/password which was: vagrant/vagrant (FYI)

Since I was working on a vm the resources of the system are limited so I the system was running really slow, then I disabled the GUI after that first start and everything runs smoothly now!!

Thanks again!!!

1 Like

Glad to help out! :slight_smile:

1 Like