First time using trellis and stuck in vagrant up: Getting "Warning: Connection timeout. Retrying..."


I’d really like to start using Trellis for my wordpress developments but i’m stuck on the “vagrant up”

My environment is

  • Mac OS X “El Capitan” 10.11.3
  • Ansible
  • Vagrant 1.8.1
  • Virtual Box 5.0.16 r105871

and my vagrant plugins are:

  • vagrant-bindfs (0.4.6)
  • vagrant-hostmanager (1.8.1)
  • vagrant-share (1.1.5, system)
  • vagrant-triggers (0.5.2)
  • vagrant-vbguest (0.11.0)

I’ve really tried lots of things found on stack-overflow and other sources but nothing seems to work. I’m getting very frustrated with this. Any ideas?

Thanks in advance!!

  • JuanMa
1 Like

Have you looked through these threads?

1 Like

Hi benword!

Yes, i’ve reviewed these threads and i can’t see a clear solution on them.
Both threads seems to be relationed with router issues. Don’t think is my case as i can use other virtual machines (through vagrant) in these IP’s.

If i change the box to “precise64” the “Connection timeout” is solved by itself but the process is broken some steps after. I suppose the trellis “tasks” (vagrant, ansible, composer) are customized to work only with “trusty64”

Is there any “version” of Trellis working with “precise64”?


  • JuanMa

Here you have the details about what i’m saying

Did you try setting the vb.gui in your virtualbox settings in your Vagrantfile and see if something comes up in there?

 # Virtualbox settings
  config.vm.provider 'virtualbox' do |vb|
    # for debugging set vb.gui to true
    vb.gui = true = config.vm.hostname
    vb.customize ['modifyvm', :id, '--cpus', cpus]
    vb.customize ['modifyvm', :id, '--memory', memory]

    # Fix for slow external network connections
    vb.customize ['modifyvm', :id, '--natdnshostresolver1', 'on']
    vb.customize ['modifyvm', :id, '--natdnsproxy1', 'on']

Hi Twansparant!

Yes, i’ve also tried that but the only thing that happens is that i can see the whole boot process through the virtual box windows and at the end i’m asked the login/password to log into the system

With the default vagrant/vagrant i can log into the machine but no synced folder or any other trellis process/service has been installed/loaded in the machine.

Any other clue i can use the “vb.gui = true” for?


  • JuanMa

Seems to be the same problem. A specific vagrant box with a specific network does not work. You can start a Vagrant Box, but no others. Have do you checked what IP is assigned to your VM? If there is no IP assigned, the problem will be the same. I think there is no problem related to Ubuntu version, most likely is related to DHCP. I’m not sure, of course.

The bad new is that we can not found a solution for this problem yet. And, since it is a very difficult to replicate, due to its specific conditions, other people cant research over it. For me was a nightmare.

sorry I can not help more!

1 Like

I forget to mention. If this problem is the same, Vagrant Box should start with wifi deactivated. Maybe you can try it.

Hi aitor!!

Here there are the logs from the vagrant up and the boot.log inside the VM

Don’t understand what’s going on here. The IP assigned to the VM seems to be but the VM is only responding to

Hope these logs can help you (or someone else more DevOps than me) understand what the problem really

Thanks in advance

  • JuanMa

I mean, check the router to see what IP is assigned. It must be by default.

Also, did you try to shut down the wifi before vagrant up? (assuming you are wifi connected to router)

It seems that changing DNS server settings and using some of the popular ones solves this issue

I haven’t tested this solution deeply but after doing this change…

==> default: Waiting for machine to boot. This may take a few minutes...
    default: SSH address:
    default: SSH username: vagrant
    default: SSH auth method: private key
==> default: Machine booted and ready!

it works as is suposed to

No more default: Warning: Connection timeout. Retrying... !! :slight_smile: