Roots Discourse

Fresh install, cant access the localhost development

Hello everyone!

I’m very new to Trellis, and the last time I used Roots was when it was only a theme (that was a very long time ago). Anyway, I am trying to move away from cowboy coding, and am learning the ropes for all of the Roots ecosystem.

I’m on macOS Catalina, and installed all the dependencies from https://github.com/roots/trellis.

I have VirtualBox 6.1.12 - Vagrant 2.2.9 - trellis-cli (https://github.com/roots/trellis-cli)

I’ve followed the install from the git repo:

trellis new example.com

cd example.com

trellis up

It runs though all the steps, and as I watch it creates the VM.

At the end I get:

PLAY RECAP *********************************************************************
default : ok=124  changed=86   unreachable=0    failed=0    skipped=34   rescued=0    ignored=0 

But I don’t know if the skipped are good or bad.

I then try to access the site in my browser, but it doesn’t return anything. I’ve tried Safari, and I’ve tried Chrome. I can ping the VM machine and it returns the IP 192.168.50.5. I also tried accessing the IP in a browser but doesn’t return anything.

So am I missing something, or is this where I’m supposed to be with Trellis, and then move onto Sage and Bedrock? I watched a video from 2017 (which was very outdated to the install procedure) but they were able to access it directly after Trellis install.

My hosts file has the:

192.168.50.5    example.com
192.168.50.5    www.example.com

What’s your dev URL? Example.test? Localhost:3000 should automatically open up through browser sync when you run: yarn run start

I tried a new build with a made up LTD, and it works.

Is there an issue using .com or any real LTD? Because I tried .dev, .com, .io and they all didn’t build.

Hmm I’m not sure. I guess it’s technically possible, but .test recommended. Even .dev isn’t recommended because it’s now a real domain.