Fresh install: yarn error

I had installed a sage9 theme a few weeks ago. I came back to it today and yarn run build is showing an error:

Module build failed: ModuleBuildError: Module build failed: Error: Node Sass does not yet support your current environment: OS X 64-bit with Unsupported runtime (72)

A bit of time searching Google led me to delete node_modules and run yarn again, which is now giving even more errors:

/Users/designlobby/.node-gyp/12.3.1/include/node/v8.h:3002:5: note: candidate constructor not viable: no known conversion from 'v8::Local<v8::Value>' to 'const v8::String::Utf8Value' for 1st argument
    Utf8Value(const Utf8Value&) = delete;
/Users/designlobby/.node-gyp/12.3.1/include/node/v8.h:2995:5: note: candidate constructor not viable: requires 2 arguments, but 1 was provided
    Utf8Value(Isolate* isolate, Local<v8::Value> obj);
1 error generated.
make: *** [Release/] Error 1
gyp ERR! build error 
gyp ERR! stack Error: `make` failed with exit code: 2
gyp ERR! stack     at ChildProcess.onExit (/Users/designlobby/Sites/vvv/www/boiler/htdocs/web/app/themes/boiler/node_modules/node-gyp/lib/build.js:262:23)
gyp ERR! stack     at ChildProcess.emit (events.js:200:13)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:272:12)
gyp ERR! System Darwin 18.5.0
gyp ERR! command "/usr/local/bin/node" "/Users/designlobby/Sites/vvv/www/boiler/htdocs/web/app/themes/boiler/node_modules/node-gyp/bin/node-gyp.js" "rebuild" "--verbose" "--libsass_ext=" "--libsass_cflags=" "--libsass_ldflags=" "--libsass_library="
gyp ERR! cwd /Users/designlobby/Sites/vvv/www/boiler/htdocs/web/app/themes/boiler/node_modules/node-sass
gyp ERR! node -v v12.3.1
gyp ERR! node-gyp -v v3.8.0

I tried installing a fresh sage9 theme, but the same errors came up again when I ran yarn.

I’m not quite sure what to do now… Any ideas? :pray:

Hey @gareth - by any chance does it work when you try it with Node 10 instead of 12?


Hey @mmirus, yes it does! :sweat_smile:

Should I just carry on using node10 for now?

Thank you!!!


Glad it was an easy one to sort out! I thought that sounded familiar. Yeah, I would stick with v10 (the current LTS release) for now unless you want to spend a little time troubleshooting node-sass with v12 to see if there’s a solution.


OK that makes perfect sense. Thanks again!

1 Like

This topic was automatically closed after 42 days. New replies are no longer allowed.