Roots Discourse

Google Web Stories Conflict

Hello,

I have a site built using Sage 9. Everything is great besides my client wants to add some Google Web Stories to their site, so I added the plugin and when you view an individual story like this one - https://www.theproducemoms.com/web-stories/tik-tok-inspired-baked-feta-pasta/ it gives the error “There was an error generating the web story, probably because of a server misconfiguration. Try contacting your hosting provider or open a new support request.” Of course the host is no help :slight_smile: If I switch to the “Twenty Twenty-One” theme it works fine, but for some reason it doesn’t like Sage 9.

Has anyone ever ran into this issue before or have any ideas why this might be triggering this error? It’s stumping me and I haven’t been able to find any threads by Googling of people encountering this before.

This is my first post and I appreciate any help.

Have you checked your server logs? It may be throwing a more useful error there.

Without knowing how your theme is built, or anything about the plugin, it’s hard to guess at the problem. If it is Sage-specific, the plug-in could be hard coding template file locations based on bad assumptions or something.

The server logs only show one error. I don’t even know if it could be related though.

WordPress database error Table ‘a045cafd_639ded.wp_wprm_analytics’ doesn’t exist for query SHOW FULL COLUMNS FROM wp_wprm_analytics made by require('wp-blog-header.php’), wp, WP->main, WP->parse_request, do_action_ref_array(‘parse_request’), WP_Hook->do_action, WP_Hook->apply_filters, rest_api_loaded, WP_REST_Server->serve_request, WP_REST_Server->dispatch, WP_REST_Server->respond_to_request, WPRM_Api_Analytics::api_create_action, WPRM_Analytics::register_action, WPRM_Analytics_Database::add

If this doesn’t help what could be my next steps to help you all have more information about my theme that may help find the issue? I can provide package.json maybe a package needs updated. Just searching for anything now.

I also tried installing the Web Stories plugin on another site I built using Sage 9 and it shows the same issues. Curious if anyone else can replicate this issue?

Thanks again for the help!

After looking into this error more, it seems to be related to the recipe maker plugin that we are using. That error message isn’t related, sorry.

I am still stumped though with what in my sage 9 theme is causing this issue.

This is a pretty generic error message that isn’t helpful (haha) :frowning: If you or the plugin developer could debug some more to provide some more details then we might be able to help you out!

That is pretty funny.

I will go back and see if we can get anything else from the plugin. I feel like a ping pong, haha.

The plugin developer figured out that due to the Blade Templating it messes with their plugin. They were kind enough to make a some adjustments to an alpha version of the plugin and sent it to me to use until they can get it integrated into their next version. So, it should work fine with Sage in the future.

1 Like

This topic was automatically closed after 42 days. New replies are no longer allowed.