Grunt not generating CSS or JS files


my original Roots setup went well, all the original files showed up, but now running Grunt again and setting up Grunt Watch did this:

Running “clean:dist” (clean) task
Cleaning assets/css/main.min.css…OK
Cleaning assets/js/scripts.min.js…OK

Running “less:dist” (less) task

…which means it deleted those CSS and JS files! And, when I run Grunt Watch and edit the files (using Dreamweaver, for now), it acknowledges that the app.less files has been changed, but it doesn’t generate a new main.min.css file. I’M STUMPED! (not that it would take much to stump me, I’m a newbie to Terminal stuff).

Running “watch” task

File “assets/less/app.less” changed.

Running “less:dist” (less) task
Completed in 0.763s at Wed May 14 2014 20:27:52 GMT-0400 (EDT) - Waiting…


Could be a file/directory permissions issue.

…and if it is a permissions issue, what might I do to resolve it?

Depends a bit on your setup (OS and any software suites you use in addition to Dreamweaver for development like MAMP or WAMP). Tell us about that.

Btw, have you tried running grunt on a fresh install?

Running Mac OS 10.6.8, and MAMP. I tried re-installing everything from Node.js on up, and I got it working, but the same problem came up again. I’m not entirely sure I uninstalled Node and Grunt as it should be… I’ve done this a few times now, I’m losing track!

okay… I may have found the culprit… I was adding code from MyFonts to the LESS file, including this line:

@import url("//");

…and when I took it out, the Grunt Watch script would create the main.min.css file. When I put it back in, it would fail again, without giving any reasons why. I did a bit of searching around and found that by adding “(css)” into that line, it could work:

@import (css) url("//");

…and so far it seems to be working! I will keep an eye on it, because after all this I’m not quite convinced that’s all it was… but hoping so. Thanks for your suggestions.