Hangs at TASK [wordpress-install : Install Dependencies with Composer] **

Just updated the local repo. Am using vault now for encrypting files. Then, having issues starting up the box I upgraded my OS to Sierra, destroyed the box and am trying to create a new one with the latest Box. It now keeps on hanging at
TASK [wordpress-install : Install Dependencies with Composer] **
multiple times now. Did read this issue.
But I have not seen that error message on the missing composer.json and it hasn’t. It was there before and still is. It just hangs there and has just now for about 30 minutes without showing any error messages. Despite the fact that I am running vagrant -vvv up

This is what I found using ps aux |grep jasperfrumau

jasperfrumau      7599   0.0  0.0  2445108   2596 s000  S+    6:45AM   0:00.01 ssh -C -q -o UserKnownHostsFile=/dev/null -o IdentitiesOnly=yes -o ForwardAgent=yes -o ControlMaster=auto -o ControlPersist=60s -o StrictHostKeyChecking=no -o Port=2222 -o IdentityFile="/Users/jasperfrumau/webdesign/ianua-all/sub.domain.com/trellis/.vagrant/machines/default/virtualbox/private_key" -o KbdInteractiveAuthentication=no -o PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey -o PasswordAuthentication=no -o User=vagrant -o ConnectTimeout=30 -o ControlPath=/Users/jasperfrumau/.ansible/cp/ansible-ssh-%h-%p-%r -tt /bin/sh -c 'sudo -H -S -n -u root /bin/sh -c '"'"'echo BECOME-SUCCESS-qyisiyzmydfznpwxdpqenieyegnivkdp; LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8 LC_MESSAGES=en_US.UTF-8 /usr/bin/python /home/vagrant/.ansible/tmp/ansible-tmp-1481773550.49-169173895806600/command; rm -rf "/home/vagrant/.ansible/tmp/ansible-tmp-1481773550.49-169173895806600/" > /dev/null 2>&1'"'"''
jasperfrumau      7595   0.0  0.2  2492788  14632 s000  S+    6:45AM   0:00.06 /usr/bin/python /usr/local/bin/ansible-playbook --connection=ssh --timeout=30 --limit=default --inventory-file=/Users/jasperfrumau/webdesign/ianua-all/sub.domain.com/trellis/.vagrant/provisioners/ansible/inventory --extra-vars={"vagrant_version":"1.8.5"} /Users/jasperfrumau/webdesign/ianua-all/sub.domain.com/trellis/dev.yml
jasperfrumau      6869   0.0  0.0  2462524   1160   ??  Ss    6:37AM   0:01.02 ssh: /Users/jasperfrumau/.ansible/cp/ansible-ssh- [mux]                                
jasperfrumau      6744   0.0  0.6  2517520  52968 s000  S+    6:36AM   0:06.47 ruby /opt/vagrant/embedded/gems/gems/vagrant-1.8.5/bin/vagrant -vvv up
jasperfrumau      6743   0.0  0.0 573377516   1748 s000  S+    6:36AM   0:00.01 vagrant -vvv up

Well, after I removed the known host key for production server that was no longer correct and did a ssh-add -K I got further:

TASK [wordpress-install : Install Dependencies with Composer] ******************
ok: [default] => (item=ianua.imagewize.com)

TASK [wordpress-install : Install WP] ******************************************
System info:
  Ansible; Vagrant 1.8.5; Darwin
  Trellis at "Fix #639 - WP 4.6 compatibility: update WP-CLI to 0.24.1"
PHP Notice:  Constant WP_DEBUG already defined in
/srv/www/ianua.imagewize.com/current/config/application.php on line 87
PHP Stack trace:
PHP   1. {main}() /usr/bin/wp:0
PHP   2. include() /usr/bin/wp:4
PHP   3. include() phar:///usr/bin/wp/php/boot-phar.php:5
PHP   4. WP_CLI\Runner->start() phar:///usr/bin/wp/php/wp-cli.php:21
PHP   5. WP_CLI\Runner->load_wordpress()
PHP   6. eval() phar:///usr/bin/wp/php/WP_CLI/Runner.php:941
PHP   7. eval() phar:///usr/bin/wp/php/WP_CLI/Runner.php(941) : eval()'d
PHP   8. define()
failed: [default] (item=ianua.imagewize.com) => {"changed": true, "cmd": ["wp", "core", "install", "--allow-root", "--url=https://${HTTP_HOST}", "--title=ianua.imagewize.com", "--admin_user=admin", "--admin_password=admin", "--admin_email=admin@ianua.dev"], "delta": "0:00:01.390004", "end": "2016-12-15 05:13:11.874132", "failed": true, "item": "ianua.imagewize.com", "rc": 255, "start": "2016-12-15 05:13:10.484128", "stderr": "PHP Notice:  Constant WP_DEBUG already defined in /srv/www/ianua.imagewize.com/current/config/application.php on line 87\nPHP Stack trace:\nPHP   1. {main}() /usr/bin/wp:0\nPHP   2. include() /usr/bin/wp:4\nPHP   3. include() phar:///usr/bin/wp/php/boot-phar.php:5\nPHP   4. WP_CLI\\Runner->start() phar:///usr/bin/wp/php/wp-cli.php:21\nPHP   5. WP_CLI\\Runner->load_wordpress() phar:///usr/bin/wp/php/WP_CLI/Runner.php:904\nPHP   6. eval() phar:///usr/bin/wp/php/WP_CLI/Runner.php:941\nPHP   7. eval() phar:///usr/bin/wp/php/WP_CLI/Runner.php(941) : eval()'d code:7\nPHP   8. define() /srv/www/ianua.imagewize.com/current/config/application.php:87", "stdout": "", "stdout_lines": [], "warnings": []}

NO MORE HOSTS LEFT *************************************************************

I did a check on wp as a version issue was mentioned:

wp --version
WP-CLI 1.0.0

So that was not the issue. Analyzing the above mentioned issues resulting in:

PLAY RECAP *********************************************************************
default                    : ok=108  changed=79   unreachable=0    failed=1   

Ansible failed to complete successfully. Any error output should be
visible above. Please fix these errors and try again.

Updated the role for WP CLI to 1.0.0 in Trellis and tried again after reading this thread. But no joy. The same error again.

On my Mac Mini I have updated Trellis with the latest version. I pulled all these changes to my MBP from my Github repo and now I got further again, but still had an error:

Loading composer repositories with package information Installing
dependencies (including require-dev) from lock file - Removing wpackagist-
plugin/woocommerce (2.6.8) [RuntimeException] Could not delete
web/app/plugins/woocommerce/assets/css/_animation.scss: install [--prefer-
source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--no-custom-
installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest]
[-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-
authoritative] [--ignore-platform-reqs] [--] [<packages>]...
failed: [default] (item=ianua.imagewize.com) => {"failed": true, "item": "ianua.imagewize.com"}

So I decided to remove the composer.lock file. Then did a vagrant destroy and vagrant -vvv up And now I am back in business!

1 Like