Having problem setting up Sage

I am trying to set up Sage and I’ve got it to work but the background images are using incorrect URLs:


it is using this one while the correct one is:


That is what happens through Apache. With the development server I just get the following error:

Cannot GET /

Any ideas?

I did rename the theme to “almayun” and did change it in “style.css”, do I have to change it somewhere else? I searched for “sage” in the theme folder but found no other references that need changing.

I’ve installed Sage as described here.

The only things I changed are the theme name and some CSS.

I haven’t used Bedrock.

Can you show the code you are using to request the background image?

Also, check your public path setting:

// bud.config.js

   * Set public path
   * @see {@link https://bud.js.org/docs/bud.setPublicPath}

Yes, that solved it. Thanks! Did not see that. Still having problems with the development server though. No matter what page I request I keep getting: Cannot GET /sample-page/.

And in the access log I just get:

"GET /bud/hot HTTP/1.1" 404 143445 "http://almayun.local/sample-page/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36"

and there is nothing in the error log.

If you’re not using bedrock, how is your local environment configured?

I am running WordPress on ZorinOS with Apache and PHP 8.1 with Node 18. All running locally not with Docker or something else.

Though, Apache is not relevant as under it the site runs fine. But the other bits are relevant for the dev server.

Hi @petethewiard,

Have you updated your setProxyUrl() call in bud.config.js? It should be set to your local HTTP hostname - almayun.local in this case.

If that doesn’t fix things, can you share your full bud.config.js file?

Cannot GET /../ is a response from Bud, and would point to a bad upstream configuration.

Your Apache log entry GET /bud/hot HTTP/1.1" 404 is expected, and is not an error. /bud/hot is provided by Bud’s HMR server.

1 Like

That solved. Initially I deleted the setProxy call as thought I don’t need it because I was not using a reverse proxy. Anyway, thanks!