Having Problems Getting Started with Trellis

I am a bit unclear as to how to get started.

I have downloaded and installed all the dependencies (except for Ansible, since I am working on Windows 10 and I understand that it will automatically get installed once I run vagrant up).

For the record – I downloaded and installed Virtual Box 5.0.2 for what’s it’s worth.

Now, my first question is whether or not I should create a new server using Virtualbox or does that happen when I install trellis? From what I understand, trellis is going to do this, but I’m not sure.

My next question has to do with the very first step in the installation process. I used the following command in cmder:

git clone --depth=1 git@github.com:roots/trellis.git && rm -rf trellis/.git

And I get the following error when I run that command:

Cloning into ‘trellis’…
Warning: Permanently added the RSA host key for IP address ‘’ to the list of known hosts.
Permission denied (publickey).
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

Any idea what I’m doing wrong?

Clone the https URI instead.

That did it – thanks.

What about creating a virtual server – do I just follow the trellis docs and that will get taken care of, or am I supposed to do that via VirtualBox before I begin?

Yup, you got it, follow the remaining docs and you should be good to go. Don’t forget to search the forums if you end up with an issue—chances are, someone else has had it before :+1:t2:

Thanks - much appreciated.

If I could make one recommendation – perhaps update the docs to a) let people know that the server will automatically be configured and b) that you can use the https: URI instead.

Are you following the docs?

Yes - I am following the docs.

I found the solution. I needed to download Microsoft Visual C++ 2010 SP1 Redistributable Package (x86).