Roots Discourse

Hirak/prestissimo at version @stable has an incompatible requirement

hello all, vagrant up is failing on a fresh ubuntu machine.

I am getting error "Package hirak/prestissimo at version @stable has a PHP requirement incompatible with your PHP version, PHP extensions and Composer version"

looks like it’s about recently relealsed Composer 2.0.0 and hirak/prestissimo package incompatibility.

Is there way to remove prestissimo from required packages or use older composer version? Thanks

full output
TASK [composer : include_tasks] ************************************************
included: /home/vagrant/trellis/vendor/roles/composer/tasks/global-require.yml for default

TASK [composer : Install configured globally-required packages.] ***************
System info:
  Ansible 2.9.10; Vagrant 2.2.10; Linux
  Trellis Head
---------------------------------------------------
non-zero return code
Changed current directory to /root/.composer
Do not run Composer as root/super user! See https://getcomposer.org/root for
details


  [RuntimeException]
  No composer.json present in the current directory, this may be the cause of
the following exception.



  [InvalidArgumentException]
  Package hirak/prestissimo at version @stable has a PHP requirement
incompatible with your PHP version, PHP extensions and Composer version

quickly removed prestissimo from global_plugines somewhere in ansible files, got another error of a similar kind:

The "composer/installers" plugin was skipped because it requires a Plugin API
version ("^1.0") that does not match your Composer installation ("2.0.0").

looks like I need to downgrade requirements from composer 2.0.0 to 1.10.17 somewhere.

I edited these lines in my group_vars/all/main.yml file to fix this:

composer_keep_updated: false
composer_version: '1.10.17'
#composer_global_packages:
 #- { name: hirak/prestissimo }
1 Like

See the recent thread about this. The solution from @Twansparant is correct too.

1 Like

thanks all, I can’t mark two replies as solutions though :slight_smile: