How can I disable SSL

I have a staging server running fine with Letsencrypt ssl enabled. However, I’m trying to disable SSL temporarily to run some tests. When I set enabled:false and run ansible playbook and/or deploy it seems SSL is disabled, but my site URL is not changed from https:// to http:// resulting in errors in Chrome.
I can open my site in Firefox by adding an exception, and when I look in my WP-settings I can see that the site URL is indeed still https://…

I have already changed my env: wp_home and env: wp_siteurl.

Can you help me out?

Hi @jurgenv,

Have you re-provisioned the server or just re-deployed? As I believe you’ll need to do both. Also, I think there’s a redirect that’ll probably be cached browser-side that you’ll need to clear too.

1 Like

I have in fact re-provisioned the server. Cache clearing does not seem to help.

This is from my ansible log. I’m not sure what it means but it names https, which maybe it shouldn’t?

TASK [ferm : ensure iptables INPUT rules are added] ****************************
ok: [] => (item={u’dport’: [u’http’, u’https’], u’type’: u’dport_accept’, u’filename’: u’nginx_accept’})

In all further output I only see the http:// URL, so that’s looking good:

TASK [wordpress-setup : Create database of sites] ******************************
ok: [] => (item={‘value’: {u’multisite’: {u’enabled’: True, u’subdomains’: True}, u’branch’: u’master’, u’cache’: {u’duration’: u’30s’, u’enabled’: False}, u’repo’: u’’, u’ssl’: {u’enabled’: False}, u’local_path’: u’…/medialog-multisite’, u’env’: {u’domain_current_site’: u’’, u’db_user’: u’medialog_user’, u’disable_wp_cron’: True, u’wp_siteurl’: u’’, u’db_name’: u’medialog_staging’, u’wp_env’: u’staging’, u’wp_home’: u’’}, u’site_hosts’: [u’’]}, ‘key’: u’medialog-multisite’})

Hey, I did some extensive cache clearing. It works now. Thank you :slight_smile: