If I run yarn start things work well but if i run "yarn start run" it doesn't why?

If I run yarn start things work well but if i run “yarn start run” it doesn’t. The main.scss file does not generate any css. instead it says

ERROR Failed to compile with 1 errors 12:34:44

This dependency was not found:

* run in multi ./resources/assets/build/util/../helpers/hmr-client.js ./scripts/main.js ./styles/main.scss run

To install it, you can run: npm install --save run

Any advice?

I am using MAMP on Windows 10 btw

yarn start run is not a command provided by Sage, so I’m not sure what you expect it to do. You can see the commands Sage provides and what they do in package.json:

1 Like

hmmm I probably got it confused with something else then. sorry I might’ve been a stupid question then, as you can tell I am not very experienced but at the very least got a answer in case someone ever has the same question. Thank you so much for your help. My other issue is that sometime when I am editing stuff while on “yarn start” my browser reloads multiple times, what could that be?

Nevermind… I had the wrong path on “publicPath”: I missed a “t” duuh…

This topic was automatically closed after 42 days. New replies are no longer allowed.