In page images not showing?

Hi all,

This may seem like a silly question but having thought I had successfully installed roots onto my wordpress site I am having a issue with images appearing from the assets/img folder

So the image is in a ‘page’ wrote in wordpress using the <img> tag. src is set to 'assets/img/image1.jpg.

So my question is have i missed something during the install?

Does anyone have any suggestions?


That should work. Is main.min.css loading correctly? If no, you need to troubleshoot or disable the rewrites. If yes, then it’s most likely a permissions issue; try loading the image using the full path to confirm.

1 Like

Do you mean css related? or placed in the page itself?

Can you provide an example like?

Initial thoughts without a link would be if its css, you should be doing:


Other that would be the rewrites are completed.

The url should be root relative and start with a forward slash: src="/assets/img/image1.jpg"

quicktip try changing your permalinks to the bottom one postname, and try again. sometimes this works before anything else too.

I had the same problem and joined the forum to lookup for help. I had to put
wp-content/themes/roots/assets/img/…jpg … then it worked… I dont know if its a good way to write that way…