Initial development setup - Privacy Error

Hi all,

So I’ve been attempting to get up and running with Trellis & Bedrock for the better part of 2 days now.

I’ve followed the Trellis Docs, to the point now where my VM (Never ran into any errors, and have re-tried from scratch multiple times) is running and is pingable with the following response

PING lewiseccles.dev (192.168.50.5): 56 data bytes
64 bytes from 192.168.50.5: icmp_seq=0 ttl=64 time=0.302 ms
64 bytes from 192.168.50.5: icmp_seq=1 ttl=64 time=0.261 ms
64 bytes from 192.168.50.5: icmp_seq=2 ttl=64 time=0.339 ms

I can also curl lewiseccles.dev from my terminal & I get a response.

<html>
<head><title>301 Moved Permanently</title></head>
<body bgcolor="white">
<center><h1>301 Moved Permanently</h1></center>
<hr><center>nginx</center>
</body>
</html>

So that is a weird response but I should at least see that when I load my site in my browser. Except I don’t get that. I run into privacy errors, see below my development/wordpress_sites.yml

# Documentation: https://roots.io/trellis/docs/local-development-setup/
# `wordpress_sites` options: https://roots.io/trellis/docs/wordpress-sites
# Define accompanying passwords/secrets in group_vars/development/vault.yml

wordpress_sites:
  lewiseccles.com:
    site_hosts:
      - canonical: lewiseccles.dev
    local_path: ../site # path targeting local Bedrock site directory (relative to Ansible root)
    admin_email: ********REMOVED********
    multisite:
      enabled: false
    ssl:
      enabled: true
      provider: self-signed
    cache:
      enabled: false

Because SSL is enabled I believe it should be creating a self-signed certificate however I don’t believe this to be the case since I’m getting privacy errors. Additionally I can’t just click ‘Advanced’ in my browser and continue anyway because of HSTS.

If I disable the SSL and run vagrant provision, then attempt to curl lewiseccles.dev - I get a full web page response (Not gonna post it as it’s long but it definitely is the entire homepage as would be expected).

But I cannot visit http://lewiseccles.dev in browser since it re-routes me to https even though I don’t have any redirect to HTTPS enabled or added as a redirect in my wordpress_sites.yml.

I found the following posts and tried the suggestions in these but unfortunately neither have gotten me any further;

For good measure here is the entry in my hosts file for my development site -

## vagrant-hostmanager-start id: 973cba8c-1c53-481c-8d93-8fef6742b6a3
192.168.50.5    lewiseccles.dev
## vagrant-hostmanager-end

So everything is telling me it is up and running, but I just can’t get a connection working in the browser.

I’m really excited to incorporate Trellis, Bedrock & Sage into my development workflow so if anyone could provide additional debug steps or any help as to what I could be doing wrong, I’d really appreciate it!

Many Thanks

Could you try canonical: lewiseccles.test instead?

Wonderful, thanks for that. It is actually working now and loads without issue, over http

Can’t believe I didn’t come across that in my searching - Note to self, checkout the github repo next time!

2 Likes