Install fails: TASK [wordpress-setup : Create databases for sites]


#1

Hi folks, here is my issue while getting everything setup on production (digitalocean):
EDIT: recieving this Error by running the following command: ansible-playbook server.yml -e env=production -vvv

System info:
  Ansible 2.5.3; Darwin
  Trellis version (per changelog): "Verify `wp-cli.phar` checksum"
---------------------------------------------------
The conditional check 'site_uses_local_db and item.value.db_create |
default(true)' failed. The error was: error while evaluating conditional
(site_uses_local_db and item.value.db_create | default(true)): No first item,
sequence was empty.

The error appears to have been in
'/Users/user/dev/rtv2/trellis/roles/wordpress-
setup/tasks/database.yml': line 3, column 5, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:

- block:
  - name: Create databases for sites
    ^ here

fatal: [159.89.21.77]: FAILED! => {}

VAULT.YML

# Documentation:
vault_mysql_root_password: "psqkAULVUDyMeL6W"

# Documentation: 
vault_users:
  - name: "{{ admin_user }}"
    password: "1e66c6259b40898792ac216adf"
    salt: "jRMB764/EpB+,j(hvL98"

# Variables to accompany `group_vars/production/wordpress_sites.yml`
# Note: the site name (`example.com`) must match up with the site name in the above file.
vault_wordpress_sites:
  test.domain.com:
    env:
      db_password: "6NeW4SMnWYeGQ3Kj"
      # Generate your keys here: 
      auth_key: "-eWs-Rg+8nDb^qS/*L[6(|/Tr6hHzEwa:Za`RBBchRbRDt-f+R-L4UooDGjGOMQr"
secure_auth_key: "c7#VImJS:`{zQEDA`i#km*f>{-q2Ez8qBIB4QW)3fH/f@8WX6GKQmk902T{i+w|("
logged_in_key: "s-`5sn$V)T1j[|qNKSjs@u<9&%>/LvBWwMWzzInrls{X@$-X0T8CK^bc=b[Cr&6+"
nonce_key: "ZM;v#U(-8xEG04hH`{v:DYp&Fj8BBJdR,zNVq<B/gY]x}?%A!?<T6A|>iX5!VxgJ"
auth_salt: "z8OkjQeGFJ%T8@VeC*UiOBPtb2svCPaxd&,KiYPtC{N*?6S-P<MVB8al4eSZwJOX"
secure_auth_salt: "5IpOeSVyHl]x3Xi@>Y@o+$$9er+ms+cj/Ju|U*hf1XOAq5q&UBk^qZ3_t*Q-ahu;"
logged_in_salt: "Bcn;rY1ZjY7OP?fq(|YT^%R=K`m1`|u*3/I]yN9yBhf*hmH/49^Bc)O.Tjv{}nje"
nonce_salt: ";$ZAd.Jq4r4Hw;&n1T?738nuz;?g0Jsf*>vTFa<5MGDw/9w}92Q82a,iHD}q3ey}"

WORDPRESS SITES

wordpress_sites:
  test.domain.com:
    site_hosts:
      #- canonical: roots.test
        # redirects:
        #  - www.example.com
    local_path: ../site # path targeting local Bedrock site directory (relative to Ansible root)
    repo: git@github.com:user/repo.git # replace with your Git repo URL
    repo_subtree_path: site # relative path to your Bedrock/WP directory in your repo
    branch: master
    multisite:
      enabled: false
    ssl:
      enabled: false
      provider: letsencrypt
    cache:
      enabled: true

Whats wrong, seems to be blind on both eyes! Thank you in advance!


#2

Same error can be found in these threads:

I edited your OP so that it’s more readable, and not sure if the vault file you provided is exactly the same as what is on your machine (the salts aren’t aligned properly). Try running a YAML validator on the contents of it to make sure it’s good.