Installed Sage 9 theme, causing 500 error on localhost:3000 & sitename.dev

nginx
trellis
sage9

#1

Hello -

I’m new to Roots and excited to learn more about workflow and tools. I’ve hit a snag after installing Sage 9. I installed Trellis and Bedrock, and then installed Sage according to instructions; everything appears to have went well but when I ran $ yarn run start - in my theme folder, it opened up localhost:3000 with a ‘500 Internal Server Error - nginx’, same goes for my sitename.dev too.

When I setup Trellis and Bedrock and ran $ vagrant up - it installed packages as it should’ve and sitename.dev was loading the WP 2017 theme just fine.

Any ideas as to what I need to do? Do I need to do something with VirtualBox/VMs to enable the local environment to work.

I appreciate any help - thank you!


#2

Fixed problem by reinstalling Sage from scratch; found out later that in my original install of Sage, within the file ‘theme-name/resources/assets/config.json’ my ‘publicPath’ key was pointing to ‘app/themes/sage’ instead of ‘app/themes/theme-name’.

When I was installing Sage with Composer and was asked the laundry list of questions (theme name, author, css framework etc) I made the mistake of thinking hitting enter would default my answer to the question hint that is provided; i.e. ‘Path to theme directory (e.g., /wp-content/themes/theme-name) [/app/themes/sage]’

Let me know if this post should be taken down or if it’s helpful to share in case others have the same problem :slight_smile:


#3

Thanks for posting your solution to your own problem. Always helps when other people search for similar topics :slight_smile: