Roots Discourse

Installing composer package gives conflict error

Hi,

I want to install stiply/stiply-php-sdk for a project only when executing composer require stiply/stiply-php-sdk I get the following message back:

Problem 1
    - Root composer.json requires stiply/stiply-php-sdk ^3.0 -> satisfiable by stiply/stiply-php-sdk[3.0.0].
    - stiply/stiply-php-sdk 3.0.0 requires illuminate/support ^6.0 || ^7.0 || ^8.0 -> found illuminate/support[v6.0.0, ..., v6.20.38, v7.0.0, ..., v7.30.4, v8.0.0, ..., v8.70.2] but it conflicts with your root composer.json require (~5.6).

Anyone has a solution of idea how I can update or upgrade packages and install the new package?

Greetz

Sage 9’s composer.json has illuminate/support pinned at 5.6

You might run into issues trying to bump that version since sage-lib is expecting 5.6 for illuminate/view and illuminate/config

Assuming you’re using Bedrock/Composer with WordPress, have you tried requiring that dependency from outside of the theme at a higher level?

No I didn’t tried that. For now I have alter the script so that I don’t make use of the PHP SDK of Stiply.